It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I experience Screen Tearing in this game, is there a way to alleviate this? Forcing VSync doesn't seem to do anything, neither does Freesync.
avatar
Lurtz: I experience Screen Tearing in this game, is there a way to alleviate this? Forcing VSync doesn't seem to do anything, neither does Freesync.
Game is designed to run 30 fps. Iirc, EE allows you to set higher fps in settings (50?) and editing lua setting scripts allows even higher (90?). HOWEVER as everything in game is tied to the FPS of the game (animations, sound, music, scripts, cut scenes) everything will run twice as fast on 60 FPS and any fps setting over 30 has high change of breaking the game (sound desycting, script desyncting/breaking, cut scenes not starting or not working properly etc. essentially engine fails to keep up with pace of higher FPS) so use the feature at your own risk.

This is why Vsync does not work with this game as it already has FPS lock and Vsync tries lock the FPS to the refresh rate of your monitor (usually 60hz, 120/144hz are also used these days).
Post edited April 18, 2017 by Petrell
Forcing v-sync in AMD's Radeon Settings eliminates screen tearing in the game for me.

Here are the steps:

1. Open Radeon Settings.
2. Click on Gaming and then Global Settings.
3. Set "Wait for Vertical Refresh" to either "Always On" or "On, unless application specifies" (if you want to be able to turn off v-sync in games that support the option).
4. Turn "OpenGL Triple Buffering" ON. This isn't necessary, but might help, since the game uses OpenGL.

Supposedly, this works with all of the Enhanced Editions of the Infinity Engine games (Baldur's Gate: Enhanced Edition, Icewind Dale: Enhanced Edition, etc.).

If you don't have an AMD card, try forcing v-sync in your own graphics control panel.
Post edited January 27, 2019 by jnisbet
avatar
jnisbet: Forcing v-sync in AMD's Catalyst Control Panel eliminates screen tearing in the game for me.
Had tearing, I did what you said in Radeon Settings (Catalyst isn't developed for 3 years already!) and the game works great now.
avatar
That.Immo: Had tearing, I did what you said in Radeon Settings (Catalyst isn't developed for 3 years already!) and the game works great now.
I'm glad to hear it. Yeah, I should've said Radeon Settings. For some reason, I still thought that it was called Catalyst Control Panel. I'll edit my post for future readers.