}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I am trying to run this in Ubuntu Gnome 16.04.2. I had to install libjson0, libopenal1, and libssl1.0.0 before I could even get the game to run. Now the game runs but the screen blacks out and shows the Planescape cursor and nothing else. Once this happens I can move the cursor but I can't get out of the game or do anything else. I ended up having to force a reboot by switching to another terminal. I have tried this on both a laptop with Intel video and a desktop with nVidia video and the results are the same on both machines. Anybody have any suggestions as to what the problem may be? This works on a MacBook Pro with no issues.
Post edited April 14, 2017 by BravoDeltaLima
No posts in this topic were marked as the solution yet. If you can help, add your reply
Not a solution since I have the same problem but, for now, you can sample the game in windowed mode.

1. go to ~/.local/share/Planescape Torment - Enhanced Edition
2. edit "Baldur.lua"
3. look for ..SetPrivateProfileString('Window','Full Screen','1')
4. change it to SetPrivateProfileString('Window','Full Screen','0')
5. save the edit and relaunch the game.
You should be able to enjoy the windowed game now.

Unfortunately I haven't been able to play it in fullscreen since launch.
Not helpful, all that does is instead of having a black screen and cursor fullscreen is that I have a black screen and cursor windowed.
avatar
Sslaxx: Not helpful, all that does is instead of having a black screen and cursor fullscreen is that I have a black screen and cursor windowed.
Installing libtxc-dxtn solved the problem in ubuntu 17.04:
sudo apt install libtxc-dxtn-s2tc
avatar
shamanu2580: Not a solution since I have the same problem but, for now, you can sample the game in windowed mode.

1. go to ~/.local/share/Planescape Torment - Enhanced Edition
2. edit "Baldur.lua"
3. look for ..SetPrivateProfileString('Window','Full Screen','1')
4. change it to SetPrivateProfileString('Window','Full Screen','0')
5. save the edit and relaunch the game.
You should be able to enjoy the windowed game now.

Unfortunately I haven't been able to play it in full screen since launch.
I have the same problem, i am using windows 7, what is weird is that I downloaded the game and was able to play the game last night without a problem in full screen and everything and when I went to play the game today the game launched but it would kick me back out to the desktop but the game was still open and running on my task bar. I clicked the game on my task bar to open it but it would still kick me out back to the desktop.

**** HERE IS A BETTER FIX ****
I found out that if I open the task manager, highlight the game and instead of clicking the [ End Task ] option I pressed [ Switch To ] option it would properly switch me to the game IN FULL SCREEN MODE and I could keep playing it as if nothing where wrong. so the problem must be with the full screen option somehow.
Post edited March 15, 2018 by cgr37712