It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


currently playing this awesome game but now it seems I am stuck. When I first went into the print shop for a quest I got, I annoyed the hell out of the owner and he teleported me out of the shop. After that I couldnt enter anymore because the door is locked. Now I have the quest from Juliette to get some love letters (and after that I can talk to her about Ravels daughter....) printed but I cant enter the shop anymore? Is this some bug? I read elsewhere on the internet that patch 1.11 solves this issue. I installed PSC according to the mod guide. Will my savegames still work? Or this there another way out?
No posts in this topic were marked as the solution yet. If you can help, add your reply
You can always go to Montague in the Civic Festhall and talk to him instead. That's how I did that quest. I didn't take Juliette up on the letters' proposal.

SPOILER below:

Do you remember a letter you found in the last room on your way out of the Mortuary (at the beginning of the game) which mentioned Penn (the printshop owner)?

Well if you do, you'd recall that he's a member of the Anarchists, who claim that everyone else is corrupt and needs to be infiltrated (which is kinda like their own group, IMO). So w/that in mind, I feel its okay - if you're roleplaying a good or neutral alignment - to use an Iron Prybar to try to open his locked door, as that's the type of action his faction takes everywhere. Or get Annah to try to pick the lock, or your TNO if he has Thief levels.

An iron prybar is found early in the game in the Mortuary, and IIRC, again in the Buried Village. Mind you I never tried to open his locked door, as I never did anything for him to kick me out, but I reckon that the prybar in the game for such situations as yours, when they arise. In fact, I believe one of the stores in the Lower Ward sells iron prybars as well. I can't remember though.
Post edited January 07, 2011 by bladeofBG
I tried talking to Montague but he is not buying my lie that I have an affair with his gf, so he wants proof in written form :/ Anyways, I will try again to break the door open with the prybar though I dont have high hopes. I will also try to join the anarchists, as I have read in a another forum that the door opens then again... will see :)

I just dont want to replay so much ://
Ok... after trying to bash the door open for 10 minutes and not succeeding I did the same with Anna and lockpicking... also no success.

After that I went into the foundry and helping Bedai with destroying the warmachine of the Godsmen. I have the dialogue option to ask her about joining the anarchists, the problem now is I have to talk Penn who is hiding in his closed printing shop. Seems I have to do the whole lower/clerk ward section again...

Is there a way to hack this door open? <: Any help would be appriciated!

Going to let of some steam now with quakeworld...

so long

If you have Dak'kon in your party, I believe you can buy a Knock spell scroll from the market for him to open the print shop door. Or buy a Friends scroll, have him cast it on you to enhance your Charisma when talking to Montague. Or get a Strength enhancing spell to help you bust down Penn's door.

Failing that, I'm not sure what you can do. Though when I spoke to Montague, I juss admitted everything to him, in order for him and Juliette to work things out in truth. IIRC, you still get the same amount of xp, if that's what you're looking for.

Edit: You can also find who Ravel's daughter might be through doing Ecco's quest.

And if Friends can't be cast on you by Dak'kon, you should have enough experience under TNO's belt by now to have some levels of mage on him, wherein he can cast it on himself upon finding a scroll of that spell. What's more, as long as Dak'kon and Annah are in your party, you can switch TNO's class between Fighter, Thief, and Mage juss by choosing the right dialogue options with them, whenever you feel like it or need to.
Post edited January 07, 2011 by bladeofBG
OK I have tried everything but it wont work. Will have to reload from a earlier point and replay some parts. Installed Metro 2033 yesterday and play through this one first as I am a little frustrated :)

Thanks blade for the suggestions!
Actually you can find a love letter in Yves drawer,although you have to pick-lock it.
Herimaka: Actually you can find a love letter in Yves drawer,although you have to pick-lock it.
Thank you 7 years after!
I had the same problem as topic starter now, in 2022. I play a neutral good character, don't steal anything and was already desperate. But your advice save me from replaying a big chank of the game.
Thanks againg, it really works.