It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Game was working fine with White March installed. Since installing 2.01 patch, it fails to start a new game. On the main screen it still says version 2 ... not 2.01.

I did first try to install the standard 2.01 patch before I realised there was one especially for White March.

Unless there's an answer I'll reinstall. But I fear installing the patch again. Cos it's all so time consuming.

EDIT: Reinstalled the whole lot with ONLY the White March patch ... The game is now working ... But still displays version 2.00.

It's ok though ... I was planning to start over :)
Post edited September 03, 2015 by Tal62
Same problem here. White March patch installed successfully but version number still showing 2.0 instead of 2.0.1.

The question is: Has the update really succeded? Is this a known issue and will it be addressed shortly?
Same here.
I installed the current expansion patch, but the main game screen still shows 2.0
Doesn't seem like the patch was installed correctly as AI isn't set to the new default, but the patcher claims it was installed.
Seems from previous posts that reinstalling everything isn't going to change that.
Update: Managed to get the updating fixed by using GOG Galaxy and allowing it to check files and re-update.

Now got a proper 2.01

Seems like they have an issue with the manual patch.
I had the same issue, what I did to (seemingly) correct it and show version 2.01 on the front menu is apply the expansion patch to 2.01 first, then (unintuitively) apply the vanilla 2.01 patch afterwards. I tried this thinking it would bork the game but it starts ok and shows the correct version number, my latest game also loads ok.

Hope this helps..

thanks tony, this has solved my problem
Yeah apparently you need to apply both patches.
Not sure if the order matters or not.