It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
symptoms same as other posts - full black screen, half black screen, small black screen, nothing

don't know how to keep MacAfee from sandboxing (actually, haven't been able to get many games to run since about windows 7 - exception being deus ex II)

I notice my computer is a notebook, not a laptop. does this eliminate my game-playing?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Is this a machine you've upgraded to Win 10? If so, have a look at Settings to see what might need tweaking. I'd also suggest doing a System File clean up. The upgrade uses a fair amount of space on your C drive but, you can manually clean the bumph left behind off your machine. If your notebook has a small amount of memory, this might be a sensible move.

I've noticed from trying to upgrade my Win 8 tablet that, even though I've inserted additional memory, getting the upgrade to use that 2nd section fully appears to be problematical. Consequently, the majority of the upgrade happens using my C drive. If you have added additional memory (and you've not done so already) I'd suggest uninstalling P+C from your C drive and re-installing it on the other.

Assuming you're using a mouse rather than a touch screen pen, are you able to right click the game icon and open 'Properties'? If so, I'd suggest using the Compatibility Wizard to see what it recommends as the best option. Once you can get the game to open, you can adjust the screen resolution to what suits your notebook (from a limited range).

I've upgraded to Win 10 on my Win 7 machine and can advise that I have no problem with running and playing P + C.

Chances are you've already tried or know of these things - in which case I apologise for trying to teach you to suck eggs! But, if not, I hope the above suggestions give you some assistance.
Post edited April 08, 2016 by Polly77
pharaoh is not working with my windows 10 laptop either. It's a fresh install, game basically switch in and out from screen during the cinematics at start, then when into an actual game if freezes after whatever i do. And everything seems running at super speed. Basically this game doesn't work for me. Very silly, i hope gog will fix this, as for now this game IS NOT COMPATIBLE with windows 10.
I have updated my PC to windows 10 when it was first released and since i have installed many old games off disk such as: Roller coaster tycoon 2, Age of empires and expansions for these games. I recently attempted to install the game PHARAOH (which i installed on my windows 7 XP PC) but when i went to the install program i clicked install game and it took me back to the homepage. I tried to change the compatibility and change the font size but it still did not work!

If you had the game and you experienced these issues please tell me how you solved this.
Post edited May 17, 2016 by Love2PlayGames
I know this is post is a bit old but in case you still can't play I managed to fix this problem on my computer. I had this game working fine but then got this problem after uninstalling and reinstalling but managed to fix it by changing the Pharaoh.exe file to windows 7 compatibility.

If you don't know how to change compatibility on windows 10 fine the Pharaoh.exe file. The easiest way is if you have gog galaxy right click the game and go to manage installation then show folder. Right click the Pharaoh.exe file (for me its at the bottom) click properties, go to compatibility, tick Run this program in compatibilty mode and choose windows 7 from the drop down menu then apply. It should work then. If you still have problems like the game not responding after a while just change to an earlier compatibility like windows 98.

The game might also have a very low resolution when you launch it. (It will look really zoomed in and low quality picture) you just have to start a game and change to a higher resolution from the options menu at the top left.
Post edited June 28, 2016 by arbiter841