It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm on Rostja mission where I have to build pyramids complex + medium pyramid + sphinx.
Everything was going fine until both medium and pyramid complex achieved 53/52%.
Then workers stopped providing new blocks, stonemasons stopped building further.
When I tried to restart the game, now it says that my saves are broken...

Possible root causes:
-I built pyramids near the edge of the map and when the pyramids started to reach out of map's bound the game crashed
-I sent burial stuff while still building -> bug occurred in original Pharaoh + Cleopatra if so then well done copying bugs :)

I got a save from a few in-game-years earlier and it worked even though the burial stuff was sent. Hence, it's most likely related to the first root cause.

If anybody have contact with devs or dev team read this discussions please fix it as soon as possible 'cause it's annoying to start over again such a long mission....

If any of you guys here have any idea how to fix it without starting over please let me know.

For current players I advice you to keep your monuments away from map's edge!
I had a mastaba that stopped delivering bricks, the bricklayer was on the mastaba but couldn't work without more bricks. I was able to resume building by deleting my bricklayers guilds and replacing them. A new bricklayer was sent to the mastaba and then brick deliveries resumed.

A new patch came out today that mentions broken saves (the notes say you might be able to load previously unloadable saves), hopefully you'll be able to load your game.