It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey guys
I am trying to complete the seelah companion quest but she is nowhere to be found, nor in the infirmary where all the "sick" bodies are, not in the temple itself.

I tried to go out of the temple and in again and i keep getting the dialogue prompt between my main character and seelah but once the dialogue ends, arsinoe spawns at the infirmary door but there's no sheela to be found. I also tried to reload an older save before returning to drezen but the same thing happens. I get in the temple, the dialogue prompt happens and once it's done there's just arsinoe.

Is this a bug or am i looking in the wrong spot? Because the quests tells me that she's guarding the jewlery with the souls inside and she's waiting by the infirmary where the bodies are kept. I see the bodies on the beds and in the various rooms, but no seelah. Also some of the bodies name appear but the bodies are like stuck in the map, because if i press tab, i can see their outlines being "inside" the bedbunks. I can still see their "names" and interact with em, but it's like they're stuck in the map.


EDIT I have attached a pic that shows the body spawning "inside" the map bug.
bug.png (303 Kb)
Post edited March 16, 2022 by dadone86
This question / problem has been solved by pen311image
Yup, sadly as i thought she's supposed to be there but she is not. I just double checked watching a youtube video. Please do fix it :'

As i said i do get the conversation prompt as soon as i either return to drezen after killing youknowwho or after resting and going to the temple "manually".
Post edited March 16, 2022 by dadone86
Same here.
Seelah can however be seen in the map view standing next to Arsinoe, but as soon as I close the map view, Seelah isn't there (anymore).

EDIT: Version 1.2.1g here.
Post edited March 18, 2022 by nilfilter
This issue should be fixed with the release of hot fix patch 1.2.1h