It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Well that is frustrating..

Put in a ton of time on Saturday, 1.04 I think, and went to load this morning and see I am running 1.06+. I got my game to load once in the throne room, and went to leave the zone. I got the unity crash screen for a moment and then the game crashed.

Now the game will start, but when I try to load any saved game it instantly crashes.


Other than catharsis, any suggestions? Wait for yet more patches?
Interesting.. I wanted to see if it was a saved game corruption, so kept going further and further back in time on saved games to see if they would load.

5th one back, loaded just fine.

I then tried to load the latest save, and it loaded fine and game is running! Good news.. just odd though.
None of my loads work except it seems for a new character I tried out afterwards just for giggles. I just defeated a certain green boss, saved it, then took a break. Came back and no loading allowed. Annoying. I've been trying loads for hours now. :P