It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I can't manage to turn off the lantern in the other world, in order to teleport with the blue mist.
I tried unequip it, drop it, rest while lantern is on the floor, reload game, but the lantern buff is still on my characters and I can't teleport.
Any clue?
No clue. Send the save game to with the issue in the subject name.
Unequipping the lantern is supposed to do it (and it did for me, back in version 1.0.6 I think?).

If you have a save shortly before getting the lantern, do you encounter the same problem when you proceed from there?
Thanks, I sent my save to devs... hope they’ll find a solution...
Ok I didn't had news from devs, but I did manage to edit the save myself and it worked.
Here's what I did:
Renamed save file extension to "zip", then unziped it.
Edited Party.json, then use a beautifier to better read it.
Search for "da0b70ce16aae6149a720670761271aa" which is the ref to the lantern item (found it in the statistics.json file).
One of the parameters of the item is "m_IsOn": true
Replaced true by false
Save, then zip all the files, then replace zip extension by "zks".
Launched game, reload save and the lantern buff is gone.

Note that the lantern didn't work anymore. If you have to turn it on again you'll have to edit the file again.
Thanks for report. We are working hard on fixing bugs and every save helps us.
Unfortunately, we don't answer on emails, because there is a lot of them.