It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Every time I try to load the game I get music and no visuals. I saw the Linux fix, but is there anything to do to fix this on a windows machine? Or did I just waste money?
same here.
is there a startup parameter I can use? Windowed mode maybe?

and this thing dows the complete opposite
it opens a visible window with black screen
Post edited December 22, 2018 by mrlousyshirt
seems to be a unity problem!

Solution I found:

Games that use Unity do not work and give an error:

IndexOutOfRangeException: Array index is out of range.
at UnityEngine.Display.RecreateDisplayList (System.IntPtr[] nativeDisplay) [0x00000] in <filename unknown>:0

I went into Nvidia Control Panel. This is where I changed "Aspect ratio" to "No scaling" on the Adjust desktop size and position page (with "perform scaling on Display"). Suddenly everything was okay again. In DS3 I had options for resolutions. If I started up a Unity game with shift, the Select Monitor was no longer empty, but said "Display 1".
I tried switching back to "Aspect ratio" to see if this would break things again. It did for some games (e.g. Hearthstone), but others kept working. I also tried "Override the scaling mode set by games and programs" and that seem to work as well.