It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Everytime I fight the Necrogiant at the end of chapter 1, everything is fine except for what looks like a polygon that protrudes from the giant that recedes into the horizon (see the attached screenshots).
I haven't noticed any other problems with this game on my system. It runs as smooth as butter except for looong load times (I have vsync on). This particular problem with the Necrogiant doesn't hinder gameplay in any way, but it is kind of annoying.
I have tried playing on the lowest possible settings and I still encounter the same issue.
Does it do this in any other games?
Could be caused by:
- RAM (video card or motherboard)
- Overheating / overclocking
- Not enough power from power supply
- Specific to the drivers you're using
If your video card is overclocked, revert it to the factory settings. You could even underclock it to see if that makes a difference. Make sure it's free of dust and try leaving the case open to cool it down. If that doesn't help try using different drivers or get the latest drivers if you don't already have them. If you're sure it's not your card getting too hot or a software issue, then there might be something physically wrong with your RAM or power supply.
well, I tried underclocking my gfx card... no luck
I tried turning off SLI and running one GPU... still the same issue.
I don't have any problems with any other games though. And so far, the only level where I have encountered an issue is when I fight the Necrogiant.
Again, it doesn't affect gameplay one bit, so even if I can't fix it, it doesn't stop my enjoyment of the game. If anyone has any other ideas, however, I would be glad to try them out.
Try to download and install the game again. But first make sure You have newest drivers to Your video card.
I submitted a support ticket.
Nox_A15: Try to download and install the game again. But first make sure You have newest drivers to Your video card.

that would not help, ive seen this happen in other games, its strictly a graphics card/driver related problem.
I suggest you update your video card drivers if they are not yet the latest
They are the latest, from Aoril 2nd.
I just found this link:
It looks like there are many people with this glitch, but it's probably the only one (so big) in the game.
Well, good to know, that problem exists only in this level, and You can still finish it with this bug. As KrazyKain said - it's probably related to graphic card.
Post edited April 08, 2009 by Nox_A15
Thank you, Nox_A15. I can live with it. It doesn't hurt gameplay it just looks weird. But I have completed games with worse bugs. When I played Deus Ex, I had floors disappear and I still enjoyed the game!
If I ever find a solution I'll post it here, but for now I will get back to playing this awesome game. Thanks to all who helped.
I have the same bug. Still, it's a minor graphical glitch.
well i have NO necrogiant.. so you are lucky ;-)
I found this glitch today as well. It's in vids on youtube. So, I'm assuming it's pretty common. I find this game really oddly compelling. Wasn't sure if I was going to like it. But it's really pretty cool.
Post edited March 09, 2012 by the_bard
I have, or had the problem on the previous computer, not sure about the current one. But yeah, just a minor(Heh) visual error.
I have the same problem not really that serious, completing in the time allowed gives little opportunity to study the ghaphics too critically although I did at first spend some time believing that this was a sort of umbilical cord and the way to beat the boss was to cut / break the cord.
Maybe a sticky should be added just to tell people it's a graphic glitch and to ignore it.
Solution is to start the game from a program that have Overlay function, like steam or xfire:
Post edited June 16, 2015 by Peppins