It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have a problem a bit like the ch.1 glitch, but instead of hanging i get a crash on the load screen for ch.3 lvl.2. Every map loaded without fault until this one. I tried running both with and without Game Booster running and the same crash happens. I don't have any of my saves showing when running as administrator or with XP sp3 compatibility mode on so i would need to play all the way through again to check.
If it helps here are my specs:
Windows 7 Ultimate 32-bit
Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz
NVIDIA GeForce 8600 GTS
Creative Sound Blaster X-Fi XtremeGamer Fatal1ty Pro Series
DirectX 11
No posts in this topic were marked as the solution yet. If you can help, add your reply
A couple things you could try is to turn all graphical settings down or off, escpecially bloom just to see if it loads the level without all the fancy effects. Painkiller seems to have some bugs with some graphics settings on higher end cards.
Another thing you could try is running the game on a single cpu core and going into your sound acceleration and try changing that about.
As for administrator mode not allowing you to use the saves if you find them in C:\Users\[USERNAME]\AppData\Local\VirtualStore\ and copy them into whatever windows 7 uses as administrator that may allow you to run your saves and admin mod.
If none of this works could you please post the error message you got?
I forgot to mention in previous post that i had run with all graphics settings at their lowest settings at lowest and highest resolutions. I tried your suggestion about the sound and turned off EAX and dropped from dolby sound to miles fast 2d sound. Neither one individually nor together did it.
I don't know how to run the game on only a single core though. I don't think i ever even gave a thought to the ability to run a multiple core processor that way. If you could tell me how to do this and if it is safe enough to do I will try it.
Here is the crash data:
Stopped working
‎9/‎22/‎2009 2:59 PM
Not reported
Faulting Application Path: C:\Program Files\\Painkiller Black\Bin\Painkiller.exe
Problem signature
Problem Event Name: APPCRASH
Application Name: Painkiller.exe
Application Version:
Application Timestamp: 42d3c457
Fault Module Name: StackHash_81eb
Fault Module Version:
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 03425234
OS Version: 6.1.7100.
Locale ID: 1033
Additional Information 1: 81eb
Additional Information 2: 81eb1a5f4e926f3d5f299d5e1ac9c80c
Additional Information 3: 0e46
Additional Information 4: 0e46067c60bb4c3bfce21351816fc75a
Thank you for helping.
To run painkiller on a single core start the game up and then ctrl alt del and bring up task manager. Then go to the processes tab and find painkiller.exe and rightclick it, then select set affinity and put that to core0.
Funny thing is i knew that at one time, but i guess i forgot. I tried it and it did not work still. I just want to play a game from a few years ago, is that so wrong?! lol. Thanks again.
minus_retsej: Funny thing is i knew that at one time, but i guess i forgot. I tried it and it did not work still. I just want to play a game from a few years ago, is that so wrong?! lol. Thanks again.

Another test try disabling your sound card and use your motherboards onboard sound or no sound at all and see if the level will load up.
Still not working. I'm starting to think this is just not gonna run.
Don't give up yet this game is definatly worth the trouble of trying to get it working. You mentioned earlier you haven't set it to run in admin or windows xp compatibility because the games saves don't show up. Did you try moving the saves? I'm not entirely sure where they would need to go either somewhere along that C:\users path with admin in it or maybe even in the games folder, unfortunatly I don't have win7 yet so I can't really find it.
I would also contact gog support if you haven't done so already.
I have the same problem and I use Vista.... so it's a Windows 7 thing... :(
It seems to have happened to me again in the expansion, but I noticed that it only seems to happen at certain checkpoint saves? So, of you load something right before that checkpoint and simply try again and not die?
Maybe saving after the checkpoint and loading that would help to? I'm not sure, the checkpoint are enough saves for me....