It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

just as i get the stakegun and have to cross taht unsafe looking bridge.. the bridge goes ballistic.. i mean calling it a rubber band would be an understatement of epic proportions... this thing flings around so fast it kills me with its own power (as in it kills me, not the fall). is this a physics bug or am i just an idiot who needs to turn around and find another route?
No posts in this topic were marked as the solution yet. If you can help, add your reply
I didn't have any problems when I played it the first time, but now going back to that spot it gets funky. If I run too fast across the bridge, or if I stand still on the bridge and then jump and fire the Killer at the boards, it snaps back up and kills me. I found that by walking slowly and stopping frequently to let the bridge die down I wouldn't have any problems.
But..... it sounds like yours is a lot more severe. You're right in thinking it's a physics bug. As I don't know any alternate route, the only solution I can think of is opening the console (~) and activating God mode (pkgod) - though if you're on a harder difficulty level you'll need to quicksave, start a new game on an easier mode, activate the cheat, then quickload. The cheat will remain active until you restart the game (or type pkgod again).
Good luck. The real challenge might be staying on the bridge :S .
its ok thanks, i just took it one step at a time and jumped in the exact center (cos it went haywire everytime i stepped in the middle).. so i made it.. but thanks anyway
Hi, I'm facing this same exact problem.

I tried going real slow (one step, pause few seconds, repeat).
Regardless of what I do, there is one point approximately midway, where the bridge goes berserk and tosses me out.

Is there any software install that I am missing? I have an ATI card.

Thanks for any help, this game is great so far, but I am unable to proceed here.
Just a thought but do you have vsync on? Older games sometimes have calculations based on framerate (though I wouldn't have thought Painkiller would). If you don't have it on, then turn it on and see if it makes any difference.
Go to the video option menu and select advanced tab. Then turn off bloom and coronas.
In my case, this makes things normal.
Post edited April 30, 2011 by Fedgit
As Korell mentioned, the issue is FPS based physics. Set your max FPS to 60 (via /setmaxfps or turning Vsync on) or so and it should work fine.
Confirmed! Thank you Korell and StabbingHob!

You can experiment in-game by pressing ~ to bring up the console and then typing setmaxfps 60 followed by Return/Enter and then ~ again to close the console.

I also tried using 30, 90, 120, but they were all more problematic, so I guess 60 really is the ideal value to use?

I'm not running the GOG/Black edition of Painkiller on this machine, and /setmaxfps 60 did nothing as a command line option for the game's shortcut, which is how I interpreted the suggestion. Does that work on the GOG version?

IIRC, Painkiller uses Havok for its physics. I'm a bit surprised that a dedicated general-purpose physics engine would contain such a flaw (unless it's purely down to the way that PCF integrated it).
In fact, I think the developpers stated that they included FPS-based physics calculations on

purpose, in order to recreate the feel of the original Quake. That's why you should set a max

FPS value, or else physics (objects, but also your jumps ; I think you can abuse that to reach

secrets more easily) will get crazy, sometimes in hilarious ways ; the bridge is a good

example of this.