It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
The D3D and Glide renderers are less than ideal because they don't allow for the status bar, instead you're forced to use the rather unflattering fullscreen hud. Also Tinting appears to not work for some reason.

I managed to force Outlaws to run in software rendering on my laptop but not my Rig. I was wondering if there's a way to just force it to run in software using an ini setting or something since I had to muck around in my registry to do it.
No posts in this topic were marked as the solution yet. If you can help, add your reply
dgVoodoo 2 is required for this...
but LECDDRAW.DLL file is not available in gog version... only DOSBox forum has that file linked into a discussion...
Post edited July 14, 2017 by FulVal
Yeah, software mode is interesting, sepia effect and full hud, so no news about how to enable it in fullscreen?
As FulVal suggested, it can be done with dgVoodoo. I've just confirmed that, with it, software mode works fullscreen with the full-sized HUD and sepia effects. Here are instructions:

Note: The following is for DirectX 10 and later GPUs, since the dgVoodoo 2 wrapper requires it. For older, pre-2007 GPUs, follow the instructions at the bottom of this post for dgVoodoo 1.5, instead.

1. Download the dgVoodoo 2 wrapper.
2. Extract dgVoodooCpl.exe, MS\DDraw.dll and MS\D3DImm.dll to your game folder. Don't extract the MS folder, itself.
3. Run dgVoodooCpl.exe from your game folder.
4. Click the [ .\ ] button in the upper-right corner to set the config folder to your game folder.
5. On the General tab, set Scaling mode to Stretched, keep Aspect Ratio. That keeps the gameplay and movies in the intended 4:3 ratio (so there will be black bars on the sides on widescreen monitors) and seems to be necessary to get the nice sepia fade-in effect when maps first load.
6. Switch to the DirectX tab and set Videocard to dgVoodoo Virtual SVGA Card (this is the key setting to force software rendering).
7. Remove the checkmark from dgVoodoo Watermark at the bottom and click the OK button.
8. Run olcfg.exe.
9. Select Direct3D [HW Accelerated] and, preferably, the highest resolution that your monitor supports, then click OK.
(If you're wondering what to set on the Advanced page, it doesn't seem to me to make any difference when forcing software mode.)
10. Once you're in a level, press the minus (-) key to bring up the full-sized HUD (i.e. make the gold bar which says "ammo," "health," etc. appear at the bottom).

Note: When a level starts, you may get a warning message about failing to enable 3D acceleration. You can ignore it because you want it disabled to get software rendering.

Note #2: There's another method that involves adding LECDDRAW.DLL to give you a "DirectDraw" option in olcfg.exe, but I found that it still requires dgVoodoo and limits you to no higher than 800x600 (with the method above, you can go up to 1600x1200).

Edit: Here are the instructions for pre-DirectX 10 GPUs:

1. Download the dgVoodoo 1.50 Beta 2 wrapper.
2. Extract dgVoodooSetup.exe, glide.dll and glide2x.dll to your game folder.
3. Download and extract [url=http://jkdf2.com/files/ddraw_(hack_viewport3_clear2).zip]this ddraw.dll wrapper[/url] to your game folder.
4. Run olcfg.exe and select 3Dfx Glide mode.
5. Once you're in a level, press the minus (-) key to bring up the full-sized HUD (i.e. make the gold bar which says "ammo," "health," etc. appear at the bottom).

If the game doesn't automatically run in software mode or not how you'd like, run dgVoodooSetup.exe and play around with the settings in it.
Post edited August 02, 2017 by jnisbet
Thanks, that's even better!
Though i don't have any warning messages when loading the level..
It doesn't work with Windows 10 fall creators update...