It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

There is a challenge called "Hard-nosed" on Ritual Sacrifice (Pro Scene 2 on Curse of the Aztec) that requires you to "Pull a Noseslide to 360 Hardflip as part of a level-long combo". A Noseslide is a simple down grind, but a 360 Hardflip is right-up-left-down. The problem is that even though I can consistently do a 360 Hardflip on the ground, I absolutely cannot do it after a Noseslide. Every time that I'm not told that I only did a Nollie, I end up doing an "Impossible", which is down-right-up-left. I did see someone do this challenge in a video, but that was on either the PS4 or Vita version of the game. Is this a bug? It seems like the game can't be made to not read the down input from the Noseslide as the beginning of whatever trick I pull out of it, and even though I'm doing the inputs for the 360 Hardflip it's almost like it cuts the input off because it doesn't read the switch from left to down. I am using a controller, if that matters.

So, has anyone here done this challenge? Can we confirm that it's not a bug? On a Trophy guide for the Playstation version I actually saw the author say it was an easy combo to pull off, so I'm really confused. If this challenge is possible on PC, then if anyone here could explain what I'm doing wrong I would really appreciate it. I feel like I've tried everything at this point, which is the only reason why I'm concerned that this is more than just me being bad at the game.

EDIT: Alright, it's definitely possible and I don't think it's bugged, but the timing can be a bit weird. After even more trial and error, I found that the key to doing this is to start the grind, slowly shift the stick to the right, and then quickly execute the trick. That's what worked for me, anyway.
Post edited August 24, 2015 by Marioface5
No posts in this topic were marked as the solution yet. If you can help, add your reply