It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello there, I recently bought Nox from and it's not working on Windows 7 64-bit as described. I already have the original game and it's quite difficult to get it to run properly so I thought "finally, a way to play this again". The game wasn't expensive and download/installation went quite well but it's not working as intended.

I installed and started the game from the shortcut and the intro video is just black, then a flickering/black version of the Nox logo/splashscreen comes up and then it hangs. Gog advertised this as being combatible to Windows 7 (32 & 64 bit), so far it seems that this is not true.

It is possible to run the game with "-window" at the shortcut and 16bit colour depth, BUT that means NO VIDEOS AT ALL as they will not play in windowed mode and you get horrible tearing, there is no way to have vsync when playing in a window or windowed. Furthermore, as soon as you open a menu ingame the framerate seems to go up/interface animations are too slow.

Guys, I really like your gog project, being a fan of CD Project for quite some time and all but if you do not have any idea on how to get the old games running on newer systems or how to build a proper wrapper then don't try to sell them. People will see this as nothing else than a rip-off. It means that portals such as are not to be trusted and this only harms retro gaming.

Anyway, if anyone has an idea on how to fix this please post. Thank you very much in advance.
At least give us a clue else nobody on here will easily be able to help you solve this.

What are your hardware specs?
Where have you installed the game to?
What AV, Firewall, etc do you have running?
Have you tried the different compatibility modes?
Running as administrator?
Disabling visual themes?
Did you run the installer as administrator on installing the game?
Have you contacted GOG support?
Hey there, thanks for helping. I have contacted GOG support at about the time I wrote this forum post. Based on previous experiences the forum can be even more helpful, though ;)

I don't see why it would be of any help if you know any system specs besides the operating system in this case but no problem here it goes :)

OS: Windows 7 64-bit (Home Edition)
Installed the game to a custom folder under c:\custom folder\\NOX
I have tried all of the possible compatibility modes, I also tried it in VMWare btw. under XP but that's another story - it hangs after the logo movie there but that's not what I bought the game for (not that I wouldn't be grateful if you'd know a solution for that one ;))

I am running the game as an administrator, visual themes, desktop composition disabled etc. also tried running in 640x480, also tried editing various config settings such as the Nox resolution (in case you'd want widescreen, it does work with 1024x600 and -window, you cannot go further in width than 1024, though as far as I know or it will crash when you try to interacti with anything in the world, also some hexediting of the executable would be necessary)

CPU: Intel Core i7-2720QM @ 2.20 GHz x4
ARCHITECTURE: Dell/Alienware M17XR3

Thanks for any help in advance!
Hmm, seems like you've tried quite a few things already then.

You can try installing the game by running the installer as an administrator and seeing if that makes any difference. The only obvious other thing I can think of, from seeing your hardware, is that you have a quad-core CPU, so you could try forcing it to run the application under a single core only. (The simple way is, when running the application, to use the Task Manager to set the core affinity of the game to your primary core only).

Other than that, I'd try different drivers for your GPU. It is the GTX460M on that model isn't it?
Ah thanks for taking the time to post some more hints, running the installer as an admin is something I didn't try - great idea! :) Unfortunately it doesn't help. It is the GTX model indeed. Actually I am running on latest drivers, I have some other recent drivers but it's the same. I absolutely don't want to go too far back in case of drivers since my other games work quite nicely.

Any other ideas? It does work (not very good, though) in 16bit windowed mode without movies and quite heavy screentearing. The tearing is not thaaat important even if it's not very pretty, if I could at least get the movies to work in that "-window" mode I'd be happy I guess :) They should definitely remove the compatibility with Win 7 64-bit because it is misleading. I already had the game and just re-bought it because is actually offering the games with a wrapper/patches/hacks to make them work on newer systems.
Post edited July 10, 2012 by Dimadyn
Running out of ideas now. I've had a look on these forums and there really don't appear to be that many people having issues, but there are a few. And we do have users on Win7 64-bit with confirmation of a working game. I'm more leaning towards thinking it is something on your machine but how we'd find out what it has in common with the other users with issues I don't know, but then that's what GOG support should be looking at with you from your DXDIAG file.

Here are some posts I thought were of interest.

The last one suggests running GAME.EXE instead of NOX.EXE.
As such, try that, but also try different compatibility modes on BOTH of these executables. Some users have had it working with Win98 compatibility, others with XP SP3.
Hey thanks for looking into this again. I tried starting from the game.exe as suggested in one of the threads and with the Intel Integrated Graphics Chipset instead of the NVidia GTX460M (it's an Optimus system) and I can play the game in fullscreen. However, the videos are completely BLACK, only the sound plays. There must be a way to get the movies working as well. If there is someone who actually got the movies working on his Win 7 64-bit system along with the game - please let me know.

Support also answered and asked for dxdiag, as I expected most of the following suggestions did not help, however I got the idea to use my Intel Chipset instead of the NVidia graphics which is indeed something. I have told them about the remaining movie issue, maybe there is some hope still ;) Rest of the game seems to work as intended.

Btw I also tried to set CPU affinity of the executable to 0 with imagecfg.exe and it didn't change anything. Could the movie issue be a problem with playing Bink videos under 64-bit systems?
Post edited July 11, 2012 by Dimadyn
I have Win7 64 bit, just installed Nox and it plays perfectly including videos.
I have very fresh installation of windows though, only codecs I have are CCCP, and latest whql drivers for nvidia.
Hey there, thanks for posting your experiences. So you installed the game, started it via shortcut and the intro movies played as well as the game (title screen etc.)? Did you modify anything from the game before? What codecs are cccp codecs? Could you try to run it without those codecs?

Here is a screenshot of how the videos look: at first everything's black, then I skip it and then this screen comes up, flickers wildly and hangs, playing is not possible after that unless I switch to my integrated graphics but then the movies are just black - not even a single picture
Post edited July 11, 2012 by Dimadyn
This is CCCP:

These are the only codecs I installed.
I run the game with shortcut, westwood logo plays, then Nox logo, then intro, all without problem. Then main menu appears where I can set options, resolution etc, then I start new game, everything works perfectly.
I did not modify anything in the game or its files.
I suppose you already tried every compatibility modus available? Because that might be a fix too.
Yes I did. I tried all compatibility modes, all possible settings with both executables. Using command line parameters as well as no options at all.

I did join the official IRC chat for the CCCP codec and the coders there didn't see any connection between the codecs and the videos as the format Westwood used for Nox is not affected by the plugins of CCCP. I did not install it as I do not want to clutter my otherwise working system with unnecessary codecs.

If some more people can confirm that it's working with CCCP installed, I'd be willing to try.
I'm running Win7 64 bit and have no issues, but I did have to run in compatibility mode. I know this post was from a while back, but just in case there are others with this issue:

Run in compatibility mode for: Windows 98 / ME

Uncheck ( Run in 256 colors, run in 640 x 480, Disable display scaling)
Check (Disable visual themes, Disable desktop composition)

With it set up like that it's run like a charm for me.
Run in compatibility for Win98 and set your desktop color depth to 16bit. Don't do anything else. Videos work fine for me.
Hi. I just installed Nox onto my computer. I had trouble at first getting it to work but I installed the 1.2 update, but the sound doesnt work. I can't hear anything. Can anyone help me? I have tried a few things but I do not know what else to do. Thank you.
Post edited December 05, 2012 by joshlarson