It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Recently I bought NWN2 - a good game from my childhood. However playing it is impossible due to simple critical problem - the game does not save. No autosaves, no regular saves. It does allow it though, as well as an access to all the modules, so that I couldn't find a similar problem in the forum. Made savegames simply do not exist. Nothing in the list to load from. No reaction to saving with the same name either (and no files in any possible savegame directory). I can save (and thus develop) my character - but I cannot play a long game (campaigns).

What I tried:

-re-installing game
-re-loading PC
-Running both client file and launcher as an administrator
-XP (SP3) compatibility
-different characters
-going deeper in the game for autosave chances
-typing different symbols as a savegame name
-saving in different campaigns or modules
-creating savefolder by hand (both in documents on the PC and in One Drive with other NWN2 documents)

Nothing worked.

My suggestions:

Win 10 problem
Laptop problems (built-in ASUS ROG abilities may not be good with old games, e.g. ROG Gaming Center)
Additional Software problems (e.g. Razer Cortex)

Any suggestions? In the general support it is recommended to launch installation as an administrator, but Galaxy seems to install it on it own without downloading installation file separately.
Post edited February 19, 2016 by Likurg987
avatar
Likurg987: Any suggestions? In the general support it is recommended to launch installation as an administrator, but Galaxy seems to install it on it own without downloading installation file separately.
My suggestion, don't use Galaxy. Just download the three files & run setup as administrator.
avatar
Likurg987: Any suggestions? In the general support it is recommended to launch installation as an administrator, but Galaxy seems to install it on it own without downloading installation file separately.
avatar
olnorton: My suggestion, don't use Galaxy. Just download the three files & run setup as administrator.
Nope, 403 error. I should use Galaxy.
avatar
olnorton: My suggestion, don't use Galaxy. Just download the three files & run setup as administrator.
avatar
Likurg987: Nope, 403 error. I should use Galaxy.
What he means is, download the installer files separately from the web page --> account. Dont use Galaxy at all. Galaxy is known to corrupt many games while installing directly from the client. Happened to me many times. Just to go your account, find NWN2 and click the download links below.
avatar
Engerek01: What he means is, download the installer files separately from the web page --> account. Dont use Galaxy at all. Galaxy is known to corrupt many games while installing directly from the client. Happened to me many times. Just to go your account, find NWN2 and click the download links below.
As I said, 403 error. Which means I couldn't download the game from the site, but only via Galaxy. Took many days to get lucky and download it from the site (smth with changing download address). Some files were downloaded in different days. However I got it installed (as an administrator) from the site and launched it (as an administrator), changing to local account from Microsoft account... And it is still precisely the same. Saving game gives no files for loading. I can't play the game (unless playing non-stop). And this is not a galaxy issue.
When you save the game, in game does it tell you in the chat box that the game was saved successfully?
When you look in C:\Users\Username\Neverwinter Nights 2\Saves, can you see your saved games?
If you look at the properties>security tab of the C:\Users\Username\Neverwinter Nights 2\ folder, is the username you are playing the game with listed as having "Full control"?
avatar
olnorton: When you save the game, in game does it tell you in the chat box that the game was saved successfully?
When you look in C:\Users\Username\Neverwinter Nights 2\Saves, can you see your saved games?
If you look at the properties>security tab of the C:\Users\Username\Neverwinter Nights 2\ folder, is the username you are playing the game with listed as having "Full control"?
Unfortunately I see no saved games in username/documents/NN2/saves. There is no NN2 folder just in username. Though there is an empty unspecified saves folder. However there r no savefiles in the PC for this game in any folder.
User has a full control over the folder, everything is inchecked (except for special permissions), user has full administrator rights.
Tried outcheck "read only" - didn't help.

:'-(
Post edited March 15, 2016 by Likurg987
avatar
Likurg987: There is no NN2 folder just in username.
I don't understand what this means.

If the game hasn't installed properly, you will have to uninstall it, then reinstall it.
Disable your antivirus software while you install it.

Try this:
Edit the target field of the shortcut you use to start the game.
And add a space & then -home "G:\games\NWN2 Complete\User"

"G:\Games\NWN2 Complete\nwn2main.exe" -home "G:\games\NWN2 Complete\User"

Change G:\Games to where ever you have the game installed.
After you start a new game & save it, you will have a folder called User in the games root directory.
And your saves will be in there. See Pic.
Attachments:
newuser.jpg (328 Kb)
Post edited March 15, 2016 by olnorton
avatar
olnorton: Try this:
Edit the target field of the shortcut you use to start the game.
And add a space & then -home "G:\games\NWN2 Complete\User"

"G:\Games\NWN2 Complete\nwn2main.exe" -home "G:\games\NWN2 Complete\User"

Change G:\Games to where ever you have the game installed.
After you start a new game & save it, you will have a folder called User in the games root directory.
And your saves will be in there. See Pic.
This actually worked. Thanks a lot. Never would realize it would be done via shortcut change.