It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey all folks.

I Need to ask you for some technical help as I am stuck. I am trying to host a server on a linux Debian 9 distribution, 64 bit architecture. Everything is fine if only players connect, however if a dungeon master logs in the server crashes (program goes in stack overflow). My Guess is that nwserver tries to refer to some shared GCC libraries which are in the 64 bit version, as in a server with a 32 bit architecture I didn't witness such a problem and DMs log in just fine (Debian 7, 32 bit).

I already tried both with compatible libraries and a chroot solution, but nwserver keeps on referencing to some libraries that should Be compatible (they are found under the i368 folder) but that return some error. What could I do to host the server? Of course I Need a DM access, and I can't switch to a native 32 bit architecture. If I tried to substitute the hard way the libraries with the Ones that are working from the other server (Debian 7 32 bit) would that cause a mess?

PS: The suspect is libc.so.6, as the error happens when nwserver attempts to read that library

Thank you!
It seems to work without any issue on a Debian Sid 64-bit, with the game installed via ./play.it, cf. attached screenshot.

By the way, I can’t see any directory named 'i386' in my game installation.
Post edited March 06, 2018 by vv221