It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Both NWN and NWN2 are doing this - it just up and started doing this after it was working fine.

I have a Samsung 4K TV and a 980TI and I've tried everything. I've tried GPU override scaling, multiple desktop resolutions, various aspect ratio settings - nothing works.

My resolution is 3840x2160 and the choices are between that and 1176x664 - no other choices. And when I select 4K it goes black with only a tiny dot visible in the lowerleft right corner...and I have to alt-ctrl-del out in order to go back to desktop.

I've also played with the CFG - but no matter what resolution I put, or if I force windowed, it just ignores it.

This is stupid.
Try putting the game into windowed mode. Then change the resolution to your desired resolution. You may need to use the ini file. Then, after it takes, switch to full screen.
Thanks but I already tried that before creating this thread. I actually had to manually edit the CFG by adding a line just to get it to go into windowed. No other resolution works in windowed mode, either. 1176x664 is the only one available no matter what I do.
avatar
Darkul81: Thanks but I already tried that before creating this thread. I actually had to manually edit the CFG by adding a line just to get it to go into windowed. No other resolution works in windowed mode, either. 1176x664 is the only one available no matter what I do.
Definitely send in a ticket.
avatar
Darkul81: Thanks but I already tried that before creating this thread. I actually had to manually edit the CFG by adding a line just to get it to go into windowed. No other resolution works in windowed mode, either. 1176x664 is the only one available no matter what I do.
That sounds more of a problem with the inf file for this monitor.
For any reason it is not seen as compatible for other resolutions. Might depend on the Hz.

NVM you can not change it, you will need to change the inf-file of the monitor.

Now begins the fun :D

IF you have a extra driver set CD or similar it is a bit easier.

okay before I continue, How tech-savy are you?

EDIT: Also please indicate when you'll be available, it might take a bit of time, but it isn't really a problem with NVM, but rather handling of windows and its drivers.....

To say it simple and only as an example, NVM wants to have 59 hertz, the inf files says only 60 Hz in this configuration (either for the monitor OR the GPU) so this resolution will NOT be displayed EVEN as both the GPU and Monitor can handle it. Have seen it sooooo often.....just because somebody forgotten to include it in the inf file.
And unticking the box in windows, only show supported modes, will not help (most of the time)
Post edited October 02, 2017 by Goodaltgamer
avatar
Darkul81: Thanks but I already tried that before creating this thread. I actually had to manually edit the CFG by adding a line just to get it to go into windowed. No other resolution works in windowed mode, either. 1176x664 is the only one available no matter what I do.
avatar
Goodaltgamer: That sounds more of a problem with the inf file for this monitor.
For any reason it is not seen as compatible for other resolutions. Might depend on the Hz.

NVM you can not change it, you will need to change the inf-file of the monitor.

Now begins the fun :D

IF you have a extra driver set CD or similar it is a bit easier.

okay before I continue, How tech-savy are you?

EDIT: Also please indicate when you'll be available, it might take a bit of time, but it isn't really a problem with NVM, but rather handling of windows and its drivers.....

To say it simple and only as an example, NVM wants to have 59 hertz, the inf files says only 60 Hz in this configuration (either for the monitor OR the GPU) so this resolution will NOT be displayed EVEN as both the GPU and Monitor can handle it. Have seen it sooooo often.....just because somebody forgotten to include it in the inf file.
And unticking the box in windows, only show supported modes, will not help (most of the time)
You're probably right - I thought it might be a problem with overscan/underscan because my actual resolution is 4096x2160 but I run 3840x2160 in 16x9. I've also had wierd issues where it keeps reseting to 59HZ and 60HZ back and forth and one time it was at 30HZ.

I'm pretty tech savvy - I built my computer and have never had a problem servicing it or fixing it myself. Software is a little tougher for me than hardware but I figure pretty much anything out.

So if you have a solution, shoot. It will be much appreciated, believe me.
Post edited October 03, 2017 by Darkul81
avatar
Darkul81: You're probably right - I thought it might be a problem with overscan/underscan because my actual resolution is 4096x2160 but I run 3840x2160 in 16x9. I've also had wierd issues where it keeps reseting to 59HZ and 60HZ back and forth and one time it was at 30HZ.

I'm pretty tech savvy - I built my computer and have never had a problem servicing it or fixing it myself. Software is a little tougher for me than hardware but I figure pretty much anything out.

So if you have a solution, shoot. It will be much appreciated, believe me.
Good ;)

So, what you need to do is to find the two inf files corresponding to your 2 devices, so your monitor and the GPU.

As I am working with W8.1 you might have to find it in a slightly different place ;)

Go to device manager and select your GPU -> properties, now you shall see a tab labelled details, in there you have to get the inf-column that will tell you the name of the inf-file being used. take a note of it ;)

Next do the same for the monitor.

Now open an explorer and go to like C:\Windows\Inf

check for those two files and juuuust in case make a backup ;)

The easiest way would be modifying your monitor-inf file.

Now it depends a bit what you see there.

so in the moment I can only give general advice:

You shall see something like:

[1920]
HKR,,MaxResolution,,"1920,1080"
maybe a few times with different resolutions.....depends on the producer ;)

the interesting part is here:

[GL2460.AddReg]
HKR,"MODES\1920,1080",Mode1,,"30.0-83.0,50.0-76.0,+,+"
HKR,,ICMProfile,0,"GL2460.icm"

the first numbers, ok no more info needed I guess ;)
the 'second' or last part whatever you want to call it ;) is about the supported frequencies. This together with the other inf file determines what you can use, it works like a mask.

If you are tech-savy enough, you can try to alter those figures, best go with the monitor inf, not the GPU one. But make sure you stay wihtin the limits....

There is also like here:

[url=http://www.videoi.com/~pietro/monitor]http://www.videoi.com/~pietro/monitor[/url]/
standard ones available, but like this one you could use ANY setting and that could be a problem!!!!!!!!!!!!!!!!

And the file only goes till 2048, so still needed to be modified ;)

Oh for the numbers, little while ago that I modified, so IIRC!!!, the first is the horizontal and the second one vertical. yeah don't ask still like in the good old days of CRT :D (actually I think it might be the other way round.....with the CRTs it was easier to tell...:D)

But if you use the same numbers as for working resolutions, shall be no problem.

And as usual disclaimer: No warranty provided on your own risk ;)

Afterwards, reinstall the monitor and you shall already see the new values. And yes I had a few times that monitor/GPU combination did not have the right values.....

Another tip, if you do have multiple max modes, you could just try with removing all but the highest, same for only leaving the Addreg modes entry....minimizes risks ;)

And for the problem you are mentioning, yes....stupid windows and a slight 'bad' cable, getting a bit interference and forces to resync....

And a little tip for the forum, do not use post message use the reply button, this way I would have seen that you replied to me and I could have told you earlier ;)

EDIT: O man....quite a long reply sorry ;)
EDIT2: https://docs.microsoft.com/en-us/windows-hardware/drivers/display/monitor-inf-file-sections a wee bit of useful information about the inf-files in general ;)
EDIT3: Or you could also send me a message via the chat option (hover over my name and click start conversation (can't do for you as default https://www.gog.com/account/settings/privacy is friends only ;) ) you can set it to anyone or friends at any time) Just be warned....not so much longer and I will go to bed :P
Post edited October 03, 2017 by Goodaltgamer
avatar
Darkul81: You're probably right - I thought it might be a problem with overscan/underscan because my actual resolution is 4096x2160 but I run 3840x2160 in 16x9. I've also had wierd issues where it keeps reseting to 59HZ and 60HZ back and forth and one time it was at 30HZ.

I'm pretty tech savvy - I built my computer and have never had a problem servicing it or fixing it myself. Software is a little tougher for me than hardware but I figure pretty much anything out.

So if you have a solution, shoot. It will be much appreciated, believe me.
avatar
Goodaltgamer: Good ;)

So, what you need to do is to find the two inf files corresponding to your 2 devices, so your monitor and the GPU.

As I am working with W8.1 you might have to find it in a slightly different place ;)

Go to device manager and select your GPU -> properties, now you shall see a tab labelled details, in there you have to get the inf-column that will tell you the name of the inf-file being used. take a note of it ;)

Next do the same for the monitor.

Now open an explorer and go to like C:\Windows\Inf

check for those two files and juuuust in case make a backup ;)

The easiest way would be modifying your monitor-inf file.

Now it depends a bit what you see there.

so in the moment I can only give general advice:

You shall see something like:

[1920]
HKR,,MaxResolution,,"1920,1080"
maybe a few times with different resolutions.....depends on the producer ;)

the interesting part is here:

[GL2460.AddReg]
HKR,"MODES\1920,1080",Mode1,,"30.0-83.0,50.0-76.0,+,+"
HKR,,ICMProfile,0,"GL2460.icm"

the first numbers, ok no more info needed I guess ;)
the 'second' or last part whatever you want to call it ;) is about the supported frequencies. This together with the other inf file determines what you can use, it works like a mask.

If you are tech-savy enough, you can try to alter those figures, best go with the monitor inf, not the GPU one. But make sure you stay wihtin the limits....

There is also like here:

[url=http://www.videoi.com/~pietro/monitor]http://www.videoi.com/~pietro/monitor[/url]/
standard ones available, but like this one you could use ANY setting and that could be a problem!!!!!!!!!!!!!!!!

And the file only goes till 2048, so still needed to be modified ;)

Oh for the numbers, little while ago that I modified, so IIRC!!!, the first is the horizontal and the second one vertical. yeah don't ask still like in the good old days of CRT :D (actually I think it might be the other way round.....with the CRTs it was easier to tell...:D)

But if you use the same numbers as for working resolutions, shall be no problem.

And as usual disclaimer: No warranty provided on your own risk ;)

Afterwards, reinstall the monitor and you shall already see the new values. And yes I had a few times that monitor/GPU combination did not have the right values.....

Another tip, if you do have multiple max modes, you could just try with removing all but the highest, same for only leaving the Addreg modes entry....minimizes risks ;)

And for the problem you are mentioning, yes....stupid windows and a slight 'bad' cable, getting a bit interference and forces to resync....

And a little tip for the forum, do not use post message use the reply button, this way I would have seen that you replied to me and I could have told you earlier ;)

EDIT: O man....quite a long reply sorry ;)
EDIT2: https://docs.microsoft.com/en-us/windows-hardware/drivers/display/monitor-inf-file-sections a wee bit of useful information about the inf-files in general ;)
EDIT3: Or you could also send me a message via the chat option (hover over my name and click start conversation (can't do for you as default https://www.gog.com/account/settings/privacy is friends only ;) ) you can set it to anyone or friends at any time) Just be warned....not so much longer and I will go to bed :P
Okay, this is complicated.

I found the files but couldn't find what you were talking about anywhere in them (I did a ctrl f search).

Here they are...maybe you can make more sense of them (if you have a moment). My computer is extremely clean btw.

Monitor INF:

https://ufile.io/db2g3

oem84 INF:

https://ufile.io/rcirg
avatar
Darkul81: snip
still here and as I suggested use chat ;)
avatar
Darkul81: snip
avatar
Goodaltgamer: still here and as I suggested use chat ;)
how do you use chat?
avatar
Goodaltgamer: still here and as I suggested use chat ;)
avatar
Darkul81: how do you use chat?
hover over my name wait a sec you get a drop down menu and click on start conversation
It won't let me - says something about privacy settings. Is it on your end or mine? I never disabled them that I know of but I looked and couldn't find anything in my settings page.