It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi All,

Finally got the download working (thanks GOG!) but im now faced with a major FPS problem.

I have done all the tweaks about setting the affinity, changing to windowed mode, download the Open GL fix, but the game is totally unplayable, im getting 2 FPS in the starting area, i cant even play the game, Char creation was so clunky, less than 12 FPS during that..

Any ideas? Im a I5@3.4 8GB ram, windows 8 and an ATI 7950.

Thanks!
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
AlexHaden: Hi All,

Finally got the download working (thanks GOG!) but im now faced with a major FPS problem.

I have done all the tweaks about setting the affinity, changing to windowed mode, download the Open GL fix, but the game is totally unplayable, im getting 2 FPS in the starting area, i cant even play the game, Char creation was so clunky, less than 12 FPS during that..

Any ideas? Im a I5@3.4 8GB ram, windows 8 and an ATI 7950.

Thanks!
Have you updated all of your drivers recently? Sound and graphics?

If all of the above is updated/upgraded, please write to us and make sure your DxDiag is attached to your support email. Thanks :D
Have you already tried to select a different sound provider in the audio options? The game is very picky about sound stuff...
avatar
JudasIscariot: Have you updated all of your drivers recently? Sound and graphics?
I have a very similar PC and have faced some problems with old games (nwn included). After a little googling, I THINK that it is ATI's new drivers fault (both stable and beta).

So, a possible experiment could be try and download some old driver and see if it fixes.
I didn't do that (lack of time/laziness), but by playing around with compability options and a quick look to these forums, I was able to run nwn without issues.
avatar
AlexHaden: Hi All,

Finally got the download working (thanks GOG!) but im now faced with a major FPS problem.

I have done all the tweaks about setting the affinity, changing to windowed mode, download the Open GL fix, but the game is totally unplayable, im getting 2 FPS in the starting area, i cant even play the game, Char creation was so clunky, less than 12 FPS during that..

Any ideas? Im a I5@3.4 8GB ram, windows 8 and an ATI 7950.

Thanks!
avatar
JudasIscariot: Have you updated all of your drivers recently? Sound and graphics?

If all of the above is updated/upgraded, please write to us and make sure your DxDiag is attached to your support email. Thanks :D
Nice one :-) Do they make you work sundays? I hope you get paid extra!

All drivers updated, i'll do as you suggest and submit a support request with DX Diag attached :-)
avatar
JudasIscariot: Have you updated all of your drivers recently? Sound and graphics?

If all of the above is updated/upgraded, please write to us and make sure your DxDiag is attached to your support email. Thanks :D
avatar
AlexHaden: Nice one :-) Do they make you work sundays? I hope you get paid extra!

All drivers updated, i'll do as you suggest and submit a support request with DX Diag attached :-)
No one "makes" me work Sundays. :P

Was in the neighborhood, so to speak, and saw your query. Figured I'd answer :D
avatar
JudasIscariot: Have you updated all of your drivers recently? Sound and graphics?
avatar
javihyuga: I have a very similar PC and have faced some problems with old games (nwn included). After a little googling, I THINK that it is ATI's new drivers fault (both stable and beta).

So, a possible experiment could be try and download some old driver and see if it fixes.
I didn't do that (lack of time/laziness), but by playing around with compability options and a quick look to these forums, I was able to run nwn without issues.
I personally don't recommend rolling back drivers because that could end up screwing up other games for people. I would also hate to be the one responsible for that. Feel free to try rolling back your AMD drivers but at your own risk.
Post edited April 07, 2013 by JudasIscariot
avatar
AlexHaden: Nice one :-) Do they make you work sundays? I hope you get paid extra!

All drivers updated, i'll do as you suggest and submit a support request with DX Diag attached :-)
avatar
JudasIscariot: No one "makes" me work Sundays. :P

Was in the neighborhood, so to speak, and saw your query. Figured I'd answer :D
avatar
javihyuga: I have a very similar PC and have faced some problems with old games (nwn included). After a little googling, I THINK that it is ATI's new drivers fault (both stable and beta).

So, a possible experiment could be try and download some old driver and see if it fixes.
I didn't do that (lack of time/laziness), but by playing around with compability options and a quick look to these forums, I was able to run nwn without issues.
avatar
JudasIscariot: I personally don't recommend rolling back drivers because that could end up screwing up other games for people. I would also hate to be the one responsible for that. Feel free to try rolling back your AMD drivers but at your own risk.
Sorted!

Thanks to everyone who's helped me pinpoint the error and thanks to GOG for taking time out on a sunday to help!

Turns out that Open GL is broken in the latest ATI Radeon Beta Drivers (the ones im using), so i decided to drop back to 13.1 and guess what?

Yes, it works perfectly!

Yay!

Anyway, if you are having issues and you are running ATI beta drivers, try non-beta drivers, worked for me!

Thanks again everyone!
avatar
AlexHaden: blablabla
Thanks for confirming my suspects! Have fun :D
I'm having the same FPS issues I JUST updated my drivers, now using 13.4 How can I contact you guys with my direct x Diagx?
For me, renaming nwnmain.exe to another name (I think I used nwngame.exe) did the trick of making the game work again.

Here's a rather many-steps guide to using old ATI 0drivers just in NWN, so you wont mess the rest of the system.
Let me know if it helps, I didn't need to try because just renaming the exe worked.


----
Edit. Add the link as well, don't just say you did...
http://nwn.wikia.com/wiki/Catalyst_video_driver
Post edited May 11, 2013 by Jarmo
avatar
Jarmo: For me, renaming nwnmain.exe to another name (I think I used nwngame.exe) did the trick of making the game work again.

Here's a rather many-steps guide to using old ATI 0drivers just in NWN, so you wont mess the rest of the system.
Let me know if it helps, I didn't need to try because just renaming the exe worked.
where is the guide exactly ^^;;?
avatar
JasmineMoldovia: where is the guide exactly ^^;;?
Ehh.. I was sure I had posted it earlier. Edited.