It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have written a guide to answer the most common questions/issue that arise from not being able to launch the nwn2tooltset.exe in Windows 10 in the year 2020.

[Where is the Tool Set ? ]
-it is located in C:\GOG Games\Neverwinter Nights 2 Complete

[What is the name of the launch file]
-it's default name is nwn2toolset.exe

[My toolset wont launch]
follow these instructions:

-The common solution is to turn off (set to : use application settings) the Threading (or multithreading) 3d option for NVidia, Hyperthreading for Intel chipsets, or the Tinseling 3d option for AMD / Radeon .

-Your mileage may vary as to where these settings are depending on your graphics card management software. But it should resolve your issue.

-After launching the application it should prompt to install Directx9 and Net .2 & 3.5 , and update c+++ , let it. ( you must wait till the installer says "finished" DO NOT EXIT WHEN THE BAR LOOKS FULL).

-If they don’t update automatically , you’ll need them in the SPECIFIC VERSIONS listed, new versions will not help you out. You can get them directly from Microsoft for free.

-More often than not Directx9 is the one you’ll have to manually install.

-Create a shortcut to Nwn2toolset.exe and place it on your desktop (this is a required step!).

-In your taskbar search type “program compatibility troubleshooter” and launch the program it finds which should say something like "run programs made for previous version of windows" (ignore web results).

-The program will ask to populate a list of applications by searching your computer: Let it do so.

-On the list it populates : select the toolset shortcut you created.

-Follow the prompts (select the top option)

-When asked select “test program” it should Launch the toolset on it’s own.

-Create a new interior area in the toolset , toggle the Occlusion grind ON (top left), and select Tile sets (bottom right)

-select ant tile from the list just above and place it on the area, repeat this process a few times.

-if it works , go back to the troubleshooter and tell it, that everything worked, follow the prompts and it will save the needed settings to launch the toolset properly.

-Running the program as admin is recommended.


TLDRSummary: The program must be run with: Diretx9 specifically , Net 2 &3.5 specifically, windows XP compatibility service pack 2 specifically, in administrator mode to function properly.
Post edited September 30, 2020 by RoonBear518
Thank you so much for the information. I followed the instructions and it works now. I have a new issue though, if you know the answer to this. Once I am in the application, when I go to open a module in the mod folder, it does not see them. I cannot click on a module to open it.
I ask because I use the Toolset to add items to a module, then I have my character pick up the items. I then export the character with the items back to the main game and continue.
I love creating unique weapons and armors that you can't obtain in the game.

I also use the Toolset to create cape's or cloaks for my party, so everyone can have a cape.
Post edited November 22, 2023 by skoal937
skoal937: Once I am in the application, when I go to open a module in the mod folder, it does not see them. I cannot click on a module to open it.
When you look in the Modules folder with Explorer, do the files have the .mod extension?

In the toolset, if you select it to show "All files" , and not just .mod files, can you see them? (See Attached Pic)

If they just have a different extension, ( like .nwm) rename them to .mod
modules.jpg (225 Kb)