It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I just purchased NWN2 on here and immeidately noticed the Screen Resolution option under in game options is completely blank. Although the box is in it's place, no optional resolutions appear within it.

Any assistance would be appreciated. Thank you.

Ori
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
Oribron: I just purchased NWN2 on here and immeidately noticed the Screen Resolution option under in game options is completely blank. Although the box is in it's place, no optional resolutions appear within it.

Any assistance would be appreciated. Thank you.

Ori
What hardware have you got ?
Graphics card
Is your monitor or screen 120Hz?
I believe it is 120Hz. It's an Acer Predator 19. It has a GeForce GTX 1060
avatar
Oribron: I believe it is 120Hz.
This is the problem, but I'm not sure there is a solution.
The game checks your display drivers to see which of it's available resolutions you can run and shows you the choice, but the game has no 120Hz Refresh Rate options, so that's why there are no options to choose from.

You can try right clicking on your desktop, Display Settings > Display Adapter Properties> Monitor Tab and see if your screen can be made to run at 60Hz (see pic) But I doubt a laptop would give you that option.

You could try just going into C:\Users\Username\Documents\Neverwinter Nights 2 and edit the nwn2.ini under
[Display Options]
Set your Width=2560 Height=1440 (or whatever resolution you want.)
I would also set FullScreen=0 because windowed mode is your best chance. (you can always press Alt + Enter to change to fullscreen if it works)
You could try setting the RefeshRate=120, but I doubt the game would recognize it.
Attachments:
refresh.jpg (67 Kb)
Post edited September 04, 2017 by olnorton
Unfortunately none of that worked. I was wrong about the Hz, it's actually 75 but that would still not be recognized by the game. Appreciate the help, guess I am going to have to get used to it.
avatar
Oribron: Unfortunately none of that worked. I was wrong about the Hz, it's actually 75 but that would still not be recognized by the game.
Actually NWN2 does support 75Hz Refresh Rate, so you should be seeing those options.
The GOG installer tries to install the correct version of DirectX 9.0c but it is sometimes blocked by your antivirus software.
Don't use the web installer if you are on windows 10
Make a new temporary folder on your desktop.
Go to Microsoft http://www.microsoft.com/en-us/download/details.aspx?id=8109
And download the June 2010 runtimes to the temporary folder .
No one gets viruses from Microsoft, but you can scan the downloaded files first if you are worried, then
Disable your antivirus software.
Then scroll down and run DXSETUP.exe (see pic)
When it says, Installation Complete, you can delete the temporary folder, and re-enable your antivirus software.
Attachments:
installed.jpg (328 Kb)
Ok, so I went in and did that but still can't see the resolution options.

I went into both the nwn and nwn2 ini files and changed the Hz over manually to 75 but still can't see them.

Then I went into both ini files and changed the resolution manually over to my native resolution which is 1920x1080 and it did not effect the original resolution at all.

The game is running as an administrator.

The only thing I may have done wrong is you mentioned not using the web installer, but I do not see any other choices, such as downloading the installer.

Appreciate the assist!

Ori
Update** Alright well I just plugged in a second monitor and made it my primary display. It works just fine on that one.

Appreciate the help!
avatar
Oribron: Update** Alright well I just plugged in a second monitor and made it my primary display. It works just fine on that one.

Appreciate the help!
Could be driver related then... might be worth getting hold of the latest ones for whatever make/model the monitor is from their official site.
Had a similar problem under Win 10.
Needed to run the game on the 1st monitor, switching the displays under settings did it.