It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi, I am brand new to gog today, but a long time NWN player. Do we know if, generally speaking, the community content views the gog version of the game as 1.69 compatible?

Thanks

@MightyFeklhr
Hi sweetie,

GOG 1.69 version is not 100% compatibile with some mods from various sites. What I recommend to do is to download and update your GOG version (use 1.69 critical rebuild from NWNVault). Working perfectly fine with my version. I didn't encounter any trouble with it :)
avatar
Paszteciara: Hi sweetie,

GOG 1.69 version is not 100% compatibile with some mods from various sites. What I recommend to do is to download and update your GOG version (use 1.69 critical rebuild from NWNVault). Working perfectly fine with my version. I didn't encounter any trouble with it :)
Why did you call him/her sweetie?
avatar
Paszteciara: Hi sweetie,

GOG 1.69 version is not 100% compatibile with some mods from various sites. What I recommend to do is to download and update your GOG version (use 1.69 critical rebuild from NWNVault). Working perfectly fine with my version. I didn't encounter any trouble with it :)
avatar
Genocide2099: Why did you call him/her sweetie?
Because I like it :D
avatar
Paszteciara: Hi sweetie,

GOG 1.69 version is not 100% compatibile with some mods from various sites. What I recommend to do is to download and update your GOG version (use 1.69 critical rebuild from NWNVault). Working perfectly fine with my version. I didn't encounter any trouble with it :)
Can you give an example of a mod that GOG 1.69 is not compatible with?
avatar
Feklahr129: Hi, I am brand new to gog today, but a long time NWN player. Do we know if, generally speaking, the community content views the gog version of the game as 1.69 compatible?
For the English version.

Totally 100% 1.69.

In fact if you apply the 1.69 patch (that many suggest) after installing the English version of NWN from GoG, it will change ZERO files (I tested it).

The confusion comes in with many alternate language installs, that are in fact still version 1.68, and some unofficial patches exist to bring those up to 1.69.
avatar
Feklahr129: Hi, I am brand new to gog today, but a long time NWN player. Do we know if, generally speaking, the community content views the gog version of the game as 1.69 compatible?
avatar
PeterScott: For the English version.

Totally 100% 1.69.

In fact if you apply the 1.69 patch (that many suggest) after installing the English version of NWN from GoG, it will change ZERO files (I tested it).

The confusion comes in with many alternate language installs, that are in fact still version 1.68, and some unofficial patches exist to bring those up to 1.69.
Don't know about other languages, but for Polish version it's not an "unofficial" patch that brings it to 1.69, it's a fully official 1.69 rebuild patch.

Unfortunately, this causes the installation of Community Patch quite complex for the Polish version (don't know about others, it may be a similar case, or it may work better). I think I'll create a new thread with a tutorial on how to install Community Patch on the Polish version.
avatar
Paszteciara: Hi sweetie,

GOG 1.69 version is not 100% compatibile with some mods from various sites. What I recommend to do is to download and update your GOG version (use 1.69 critical rebuild from NWNVault). Working perfectly fine with my version. I didn't encounter any trouble with it :)
avatar
jjglvz: Can you give an example of a mod that GOG 1.69 is not compatible with?
If I remember correctly, Aielund Saga gave me a message that my version is not up to date (GOG 1.69) - English version.

Then I tried polish - same message. After installing 1.69 update it worked normally.

As Taro94 wrote, other languages version can have issues with mods but I had the same for English version. Not sure if it was only mine problem. I was aware that polish version will need a patch 1.69 installed once again.
avatar
PeterScott: For the English version.

Totally 100% 1.69.

In fact if you apply the 1.69 patch (that many suggest) after installing the English version of NWN from GoG, it will change ZERO files (I tested it).

The confusion comes in with many alternate language installs, that are in fact still version 1.68, and some unofficial patches exist to bring those up to 1.69.
avatar
Taro94: Don't know about other languages, but for Polish version it's not an "unofficial" patch that brings it to 1.69, it's a fully official 1.69 rebuild patch.

Unfortunately, this causes the installation of Community Patch quite complex for the Polish version (don't know about others, it may be a similar case, or it may work better). I think I'll create a new thread with a tutorial on how to install Community Patch on the Polish version.
As I remember it. Only the English Language Patch was subject to official QA, and is was the only officially released 1.69 patch. Which is likely why GoG only applies the English patch.
avatar
Taro94: Don't know about other languages, but for Polish version it's not an "unofficial" patch that brings it to 1.69, it's a fully official 1.69 rebuild patch.

Unfortunately, this causes the installation of Community Patch quite complex for the Polish version (don't know about others, it may be a similar case, or it may work better). I think I'll create a new thread with a tutorial on how to install Community Patch on the Polish version.
avatar
PeterScott: As I remember it. Only the English Language Patch was subject to official QA, and is was the only officially released 1.69 patch. Which is likely why GoG only applies the English patch.
Considering GOG has no objections to applying various community-created patches to their games, it is, bluntly speaking, stupid that they oppose updating the other localizations of NWN.
Post edited September 26, 2017 by Taro94
avatar
Taro94: Considering GOG has no objections to applying various community-created patches to their games, it is, bluntly speaking, stupid that they oppose updating the other localizations of NWN.
Slight correction:

It is (maybe) not GOG objecting. It is up to the dev/publisher on what THEY agree to put up. GOG can not (and will not) go against this.
Actually that GOG allows us to post freely (for this) in their forums is already a big plus!

I have seen that on other forums users posting non-official stuff on their webpages those users and or links were being removed. Not talking about illegal stuff, but even like translations and similar. Just saying ;)