It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I have successfully hosted NWN1 dedicated servers in the past but, with my new router and computer, nobody can connect.

So far I have:
1. Set my computer's local IP to a static address
2. Forwarded ports 5120-5300, 6500, 27900, and 28900 on my router to my computer's static local IP address using UDP
3. Opened UDP ports 5120-5300, 6500, 27900, and 28900 in my Windows firewall for all applications and all networks (private, public, and domain)
4. Disabled my router firewall entirely
5. Checked the "post to internet" box in the dedicated server
6. Attempted to direct connect to the dedicated server using my external IP address and port 5123

Despite this, the connection just times out. What else can I try? I have no issues connecting to persistent worlds and can even connect to the dedicated server that I set up on my brother's computer last year.

I am running Windows 10. Unfortunately, I am not able to completely disable my Windows Firewall because this is a school-issued laptop and the administrators have locked that. However, as I stated above, I have allowed all incoming traffic from ports 5120-5300, 6500, 27900, and 28900 through my Windows Firewall.

Thanks!
No posts in this topic were marked as the solution yet. If you can help, add your reply
I know you said you had the ports allowed through the firewall, but have you tried also setting up a rule for the executable to be allowed through the Windows firewall?

Do you use the client extension?

I have been running a co-op private server myself for the past year and have not had issues like you describe.
It's been many years since I've hosted my own server, but I believe the game requires both UDP *and* TCP. Try including both protocols when you configure your ports.
avatar
jimbobslimbob: I know you said you had the ports allowed through the firewall, but have you tried also setting up a rule for the executable to be allowed through the Windows firewall?

Do you use the client extension?

I have been running a co-op private server myself for the past year and have not had issues like you describe.
I forgot to mention that I have already tried allowing nwserver.exe and nwmain.exe through the windows firewall to no avail. I do use the client extension.

I'll be visiting family in two weeks, so I'll try to host a server via that router (the same one that works for my brother). If it works, then I know that I have a router/ISP issue. If it doesn't, then it must be a computer issue.

Thanks for your help! If I get any new information in two weeks, I'll post in this thread again.
avatar
Ryan333: It's been many years since I've hosted my own server, but I believe the game requires both UDP *and* TCP. Try including both protocols when you configure your ports.
Although I am quite certain that NWN only uses UDP, I tried opening up the ports with TCP as well and had no luck. Thanks for the suggestion though!
Post edited November 09, 2017 by SkyByson
Is it NAT related? Could be worth turning it on/off on your router and seeing if it makes any difference... I know it's caused issues for people in the past.
avatar
jimbobslimbob: Is it NAT related? Could be worth turning it on/off on your router and seeing if it makes any difference... I know it's caused issues for people in the past.
Turning off NAT on my router disconnects me from the internet and gives a "could not translate address" error when I try to connect to the NWN server. I also tried DMZ mode, which should bypass the router firewall entirely, and it still didn't work so I suspect either a computer or an ISP issue. Hopefully I'll be able to elucidate where the problem is coming from when I test it on a different router in a couple weeks. Thanks again for the suggestion!