It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Okay My wife and I want to play Multiplayer together. We both have our own accounts and games. When we tried to do the Multiplayer we were hit with the CD key issue. We found the solution and mine was accepted right away but hers was not. After going through it a few times we found a typo. BTW it would make it much easier if we could copy/paste for future reference and games. Anyway she jumped right in as soon as we solved hers and I went to click Multiplayer on mine. She got in and I still get the same message as though I never put them in at all. Needless to say we tried the basics ... retype all again, restart computer, delete game completely reinstall and retype keys, and a couple of variations on this to no avail. ANYONE have any other ideas?????? Running Win10 if needed.
No posts in this topic were marked as the solution yet. If you can help, add your reply