It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
All my GOG Galaxy installations are installed to my secondary SSD instead of my HDD C Drive; however, I discovered that my slow loading times for NWN2 were likely because my game is saving to the C Drive instead of the SSD it's installed on.

However, I'm struggling to change the save location to the SSD; I tried inserting "S:\Users\USERNAME\Documents\Neverwinter Nights 2\saves" into the Save line of the nwn2.ini file (and nwn.ini just to be sure), but now it simply refuses to look in either the new folder or the old one. The fact that instead of simple file paths the .ini uses lines like .\saves instead of "C:\Users\USERNAME\Documents\Neverwinter Nights 2\saves" simply makes me more confused as to what I should enter.

While a syslink will help in the meantime, I'd really rather work out how to make the game automatically use the S Drive instead of the C Drive.
This question / problem has been solved by dr.schliemannimage
You should add the "-home" option to the game's executable.

Right click on the shortcut you use to launch the game and select Properties. The Target line should currently appear like this:

"S:\Games\Neverwinter Nights 2\nwn2main.exe"
Change it as this:

"S:\Games\Neverwinter Nights 2\nwn2main.exe" -home "S:\Saves\Neverwinter Nights 2\"
Click on Apply to save the changes, then try running the game: it should create the new home in drive S:, where it will store the save data.

You can obviously set the home directory as you wish.
If you want it to be inside the game's folder, avoid setting the home to the game's folder itself, but set it to a subdirectory instead. Such as this:

"S:\Games\Neverwinter Nights 2\nwn2main.exe" -home "S:\Games\Neverwinter Nights 2\User"
Thanks for the reply; that worked quite well, though with one problem. Oddly, despite the quotation marks it wouldn't recognise "\Neverwinter Nights 2\", trying to go to "\Neverwinter" instead. Changing the name of the folder to \NeverwinterNights2 worked though, so it's not too massive a problem.

Thanks again for the help!
Glad to have helped you.
avatar
A6M_Zero: Thanks for the reply; that worked quite well, though with one problem. Oddly, despite the quotation marks it wouldn't recognise "\Neverwinter Nights 2\", trying to go to "\Neverwinter" instead. Changing the name of the folder to \NeverwinterNights2 worked though, so it's not too massive a problem.
Strange. Are you sure you used the quotation marks correctly? As you can see there are two couples of quotation marks: one for the executable's path and another one for the "home" option.
I'm not saying you made an error: I'm not sure the "home" argument can handle quotation marks for the path.

Could you please try this:

"S:\Games\Neverwinter Nights 2\nwn2main.exe" -home "S:\Saves\Neverwinter Nights 2\User"
and see if the game correctly creates that path? I can't try it myself right now.
I tried using the quotation marks as you said, but again it ignored the \Neverwinter Nights 2 and tried to create a new \Neverwinter folder instead. Double checked, and couldn't see any fault with the quotation marks placement or anything like that.
avatar
A6M_Zero: I tried using the quotation marks as you said, but again it ignored the \Neverwinter Nights 2 and tried to create a new \Neverwinter folder instead. Double checked, and couldn't see any fault with the quotation marks placement or anything like that.
Thanks for your reply.

I want to add something about your problem: many games store their save data into user's "Documents" folder by default, such as NWN2 does. If you want your games to save their data into drive S:, you could then move the "Documents" folder to that drive.
Take a look here (this guide is for Windows 10, but this method should work on Windows 7 and Windows 8.1 too).