}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hey all. I'm having a problem in Neverwinter Nights 2. It's been an ongoing problem that I just can't find a solution to. Originally I had the full game and all expansions, and I figured my issue was due to patching. At the time, the patching process was pretty funky.
So I just grabbed the complete edition here, hopingthat things would be better now. Unfortunately, I'm still having the problem. What's going on is that I have no combat sounds. Music, voices, random sound effects, such as looting/clicking on things, work fine. Just no melee sounds, spells, or even NPC chatter. I really have no idea what's going on. Anyone have any ideas?
Thanks in advance
This question / problem has been solved by DeMignonimage
I think I had similar problem when installed NWN 2 - nusic was playing just fine, but voices were missing. After reboot all sounds were working just fine.
Unfortunately, not for me. I've tried rebooting, changing sound quality in Windows, messing with the in game sound provider, all to no avail. Haven't tried messing with the .ini, but I don't know what to change, or if it would help at all.
This problem might derive from 3D sound positioning. Probably the sounds aren't gone, but very quiet. Maybe you aren't able to hear anything, because you scrolled out of the picture and the calculated volume is reduced too much.
- Try disabling 3D sound (EAX and DirectSound3D) in the sound options and fall back to 2D sound.
- Or maybe it's the other way round in your case. Enable DirectSound3D or EAX to hear 3D combat sounds

Furthermore, the 2D/3D Bias slider affects 3D sound volume too (left 3D sounds muted; right 3D sounds at full level).
- Try the slider at the most right position.

You can also try tweaking/checking the NWN2.ini file in your game folder

[Sound Options]
DisableSound=0

If set to 1, this option disables all sound in the game. While this may improve performance it's obviously not recommended. The main use would be for troubleshooting, to determine if crashes or other issues are sound-related for example.

Number 2D Voices=16
Number 3D Voices=16

These settings determine the number of audio channels to allocate to 2D (non-positional) and 3D (positional/environmental) sounds. The default is 16, though most sound cards can support 32. You can reduce this value to improve performance or reduce audio glitching, or conversely you can raise the value to increase the number of sounds possible. Remember that more audio channels equals more processing power required, especially for 3D sounds, so it can affect performance particularly with lots of positional audio (e.g. in heavy combat).

Speaker Type=0
This setting controls the speaker configuration used for sound playback in the game. The default option of 0 is for 2/2.1 speakers; a value of 1 is Surround, 2 is for Headphones, 3 for 4.1 speakers, 4 for 5.1 speakers, and 5 for 7.1 speakers. Set to match your speaker system or try the 2D variants (0, 1, 2)

MaxCachedSounds=100
This setting should determine how many sounds are held in the audio cache in memory. The higher the value, the more sounds are held and hence the less loading is required to play back a sound. Raising this value to 200 or even higher can help reduce stuttering in the game.
Post edited November 17, 2013 by DeMignon
avatar
DeMignon: Furthermore, the 2D/3D Bias slider affects 3D sound volume too (left 3D sounds muted; right 3D sounds at full level).
- Try the slider at the most right position.
Brilliant! This was the issue. I probably changed this quite some time ago, as I don't have a 3D sound system, just 2.1. So I figured I'd go straight 2D, expecting better performance. Alas, that's obviously not the correct line of thinking.

Thanks a lot for the help! Man, fights are much more dynamic now lol
You're very welcome. I'm glad it works!
While I wrote the troubleshoot concerning 3D sound, the 2D/3D slider came to mind and I thought I add the info just in case ;-)