It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Just downloaded the complete edition of Neverwinter Nights 2. The game is running fine except for when I try and do any resolution change. When the resolution is changed the game either crashes, or minimizes to a black box and flashes on and off.

I've searched the internet but have only found dead threads with no solution.

Any ideas?

Running a GTX 1060.

Thanks.
Basic troubleshooting first:

Running game as Admin?
Running in Windows 7 or earlier Compatibility?
Which OS are you using?
Do you have integrated graphics? It might be running on that. (If you do have integrated and verified you are running on gtx, try running on integrated, if same problem it's not graphic related)
avatar
alexanderros: Basic troubleshooting first:

Running game as Admin?
Running in Windows 7 or earlier Compatibility?
Which OS are you using?
Do you have integrated graphics? It might be running on that. (If you do have integrated and verified you are running on gtx, try running on integrated, if same problem it's not graphic related)
Appreciate the reply,

Nope, not running as admin.

I am running on windows 10

Not quite sure what integrated graphics is. How would I go about checking that?
avatar
alexanderros: Basic troubleshooting first:

Running game as Admin?
Running in Windows 7 or earlier Compatibility?
Which OS are you using?
Do you have integrated graphics? It might be running on that. (If you do have integrated and verified you are running on gtx, try running on integrated, if same problem it's not graphic related)
avatar
galpin13: Appreciate the reply,

Nope, not running as admin.

I am running on windows 10

Not quite sure what integrated graphics is. How would I go about checking that?
You should run it as Admin then, old games don't play nicely with UAC
Integrated graphics is part of your CPU, but it depends on CPU if it has it.

If you see Intel Graphics it means you have integrated.
avatar
galpin13: Appreciate the reply,

Nope, not running as admin.

I am running on windows 10

Not quite sure what integrated graphics is. How would I go about checking that?
avatar
alexanderros: You should run it as Admin then, old games don't play nicely with UAC
Integrated graphics is part of your CPU, but it depends on CPU if it has it.

If you see Intel Graphics it means you have integrated.
If running as Administrator doesn't help try editing the nwn2.ini file manually at the Documents/Neverwinter Nights2 folder.
high rated
Deactivate fullscreen, change everything you want incl. resolution and save. Close and restart the game and it will start in window mode. Open settings and change it back to fullscreen. Close the game, start it again and it will work.

This is the only way to fix this problem with W10 creators update. CU has some problems with older games and fullscreen.

If you want to play Drakensang River of Time, you have to use window mode and borderless gaming. The same with Dungeon Siege 2.

compatible mode and/or running as admin does not work.
Post edited May 22, 2017 by caranthir1976
avatar
caranthir1976: Deactivate fullscreen, change everything you want incl. resolution and save. Close and restart the game and it will start in window mode. Open settings and change it back to fullscreen. Close the game, start it again and it will work.

This is the only way to fix this problem with W10 creators update. CU has some problems with older games and fullscreen.

If you want to play Drakensang River of Time, you have to use window mode and borderless gaming. The same with Dungeon Siege 2.

compatible mode and/or running as admin does not work.
I'm getting a crash immediately at launch, not getting any clickable options. Also tried running as Admin (for info), didn't work.
avatar
caranthir1976: Deactivate fullscreen, change everything you want incl. resolution and save. Close and restart the game and it will start in window mode. Open settings and change it back to fullscreen. Close the game, start it again and it will work.

This is the only way to fix this problem with W10 creators update. CU has some problems with older games and fullscreen.

If you want to play Drakensang River of Time, you have to use window mode and borderless gaming. The same with Dungeon Siege 2.

compatible mode and/or running as admin does not work.
avatar
Bearclawmcbain: I'm getting a crash immediately at launch, not getting any clickable options. Also tried running as Admin (for info), didn't work.
What OS do you have ? Also it might best to create your own thread for this.
I never had a crash at launch. Don't think it's the same problem. Did you just installed the game? May something happen during the installation. In that case may it helps to deinstall it, delete the registry entries (be careful) and reinstall it.

Programs like Ccleaner are not deleting all registry entries. Sometimes you have to search for them yourself. May you don't have to delete the entries, but it can help in some cases.

The OS should not be Bears problem. The game was/is running on W7, W8.1, W10 Anni and now on W10 creators. Had a problem the first time on creators.


Edit: Bear, did you just update W10 to creators (not clean install)? I don't know what problems you can have in that case. I do a clean install every new version and install the games again.
Post edited May 25, 2017 by caranthir1976
avatar
Bearclawmcbain: I'm getting a crash immediately at launch, not getting any clickable options. Also tried running as Admin (for info), didn't work.
Try right clicking on nwmain.exe >Properties>Compatibility> Override High DPI scaling behavior.
If it isn't already checked.
See Pic.
Attachments:
nwmain.jpg (105 Kb)
avatar
caranthir1976: Deactivate fullscreen, change everything you want incl. resolution and save. Close and restart the game and it will start in window mode. Open settings and change it back to fullscreen. Close the game, start it again and it will work.

This is the only way to fix this problem with W10 creators update. CU has some problems with older games and fullscreen.

If you want to play Drakensang River of Time, you have to use window mode and borderless gaming. The same with Dungeon Siege 2.

compatible mode and/or running as admin does not work.
Thanks. This did it for me. One only wonders why it's the only way to play the game normally...
Also, there is another solution how to avoid crash. Works for me (GTX 1080, Win 10 - also crashes).

Check My Documents -> NWN2 folder and find NWN2 ini. Open it and check Display Option. You can manually enter your resolution there :) Save and quit the file, then start the game.
avatar
caranthir1976: Deactivate fullscreen, change everything you want incl. resolution and save. Close and restart the game and it will start in window mode. Open settings and change it back to fullscreen. Close the game, start it again and it will work.

This is the only way to fix this problem with W10 creators update. CU has some problems with older games and fullscreen.

If you want to play Drakensang River of Time, you have to use window mode and borderless gaming. The same with Dungeon Siege 2.

compatible mode and/or running as admin does not work.
This worked for me. Thanks!
avatar
caranthir1976: Deactivate fullscreen, change everything you want incl. resolution and save. Close and restart the game and it will start in window mode. Open settings and change it back to fullscreen. Close the game, start it again and it will work.

This is the only way to fix this problem with W10 creators update. CU has some problems with older games and fullscreen.

If you want to play Drakensang River of Time, you have to use window mode and borderless gaming. The same with Dungeon Siege 2.

compatible mode and/or running as admin does not work.
This also worked for me. Thank you so much.
avatar
Bearclawmcbain: I'm getting a crash immediately at launch, not getting any clickable options. Also tried running as Admin (for info), didn't work.
avatar
olnorton: Try right clicking on nwmain.exe >Properties>Compatibility> Override High DPI scaling behavior.
If it isn't already checked.
See Pic.
I was using the window mode instructions but still crashing, then this did the trick for me.