It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi,

I'm still getting a black screen on startup with this game. I've seen the previous 'solved' thread around this issue and older NVIDIA drivers however I'm attempting to run this on Win7 + asus eee 1001p ie 450 atom + intel 3150 graphics.

Anyone have any idea how to solve this? Driving me crazy!

I've tried compatibility mode + administrator and also launching directly from nwmain.exe, no success at all.
Since you've listed common fixes, I assume you've not got it installed to program files

Do you get any sound at all?

I take it you're running at 1024x600 (at least thats what my netbook uses), thats not an officially supported video mode but the game should be smart enough to adapt to it (I can run it at that resolution on my desktop pc).

If you load NWconfig from the install folder, can it scan the system and recommend settings?

If you manually open nwn.ini in notepad, you can type in the resolution under the [Display options] heading
avatar
Aliasalpha: Since you've listed common fixes, I assume you've not got it installed to program files

Do you get any sound at all?

I take it you're running at 1024x600 (at least thats what my netbook uses), thats not an officially supported video mode but the game should be smart enough to adapt to it (I can run it at that resolution on my desktop pc).

If you load NWconfig from the install folder, can it scan the system and recommend settings?

If you manually open nwn.ini in notepad, you can type in the resolution under the [Display options] heading
Hey mate,

Thanks for the reply - it's installed to the default Gog.com program files location.

I have run the scan, it reports 256m/2gb vid mem/ram, recommends best for video quality with 64m textures. It does change the resolution to 800x600x60 and sound to safe mode. Changing to these settings makes no difference to the outcome, basically black screen with the hand, can confirm there's no sound throughout the startup - perhaps this is important?

Cheers for the help
Heh the resolution is either never changed by the recommended settings or my monitor's resolution is outside whatever the system was made to detect, it suggests 8x6 for my full hd monitor.

It might be worth installing to some place other than program files, windows tends to be overprotective of that folder and usually won't let programs to write there
Thanks mate, tried the install to c:\nwn instead, which has yielded minor progress - the sound now works on startup, however I still hit the dreaded black screen....

res seems correct in nwn.ini - 1024x600

any other ideas? this is killing me!

thanks for all your help, well appreciated
Post edited October 31, 2010 by didymus
When it comes to video issues and NWN, the default advice is to roll back video drivers (as things get updated, the functionality NWN needs seems to disappear), but with a netbook I am not so sure that advice would be terribly effective...and my laptop uses an Intel 4500, so the "newer is less compatible" argument doesn't hold so well...but integrated graphics have often been a point of contention with gaming (the Intel chipset on my last laptop barely ran the game at all).

If I were having this problem I might tweak around with 3D-Analyzer a bit to see if I could rig up a fix by trial and error if anything could be done using that software.

As another workaround, you could try creating a shortcut that immediately tries to load a non-existent module, which will fail and result in you getting dumped to the module load screen rather than the main menu, at which point you could click cancel to go back to the main menu. You will want the following as your target for the shortcut (assuming you don't have a modulename.mod file in your NWN\modules directory):

C:\[InstallationDirectories]\NWN\nwmain.exe +TestNewModule "modulename"
Awesome mate, you've steered me in the right direction!

For anyone out there with an intel 3150 graphics card (pinetrail netbooks?) you'll need to downgrade your intel driver from x.x.x.2117 to x.x.x.2023 - works fine after this (with the exception of the metallic character bug noted in a separate thread...)

cheers massively mate
avatar
didymus: Awesome mate, you've steered me in the right direction!

For anyone out there with an intel 3150 graphics card (pinetrail netbooks?) you'll need to downgrade your intel driver from x.x.x.2117 to x.x.x.2023 - works fine after this (with the exception of the metallic character bug noted in a separate thread...)

cheers massively mate
Well thsats good news, especially since I solved the silver chracter problem
http://www.gog.com/en/forum/neverwinter_nights_diamond/customization_issues_with_color/post33