It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

This game used to work out of the box for me. Problems only arrived after installing it on Windows 7 x64. I was using Windows 7 32 bit previously and did not made any hardware changes since then.

Downloading these two files Atlantico posted helped me to fix the video sequences. Thank you very much for that!

The only weird thing was, I had to disable the "Show environmental effects on characters" option. Otherwise, every character in the world would become invisible. I guess this particular game isn't completely prepared to work out of the box on newer systems after all, which is a bit dissapointing.

Some of my system specs, just in case anyone has similar issues:

Windows 7 Ultimate 64-bit
AMD FX-4300
Vishera 32nm
4,00GB DDR3 @ 669MHz (9-9-9-24)
ASUSTeK Computer INC. M5A78L-M LX3 (AM3R2)
SyncMaster (1024x768@85Hz)
1024MBATI AMD Radeon HD 6800 Series (XFX Pine Group)
298GB Western Digital WDC WD3200BPVT-22JJ5T0 ATA Device (SATA)
298GB Western Digital WDC WD3200BPVT-22JJ5T0 ATA Device (SATA)
932GB Western Digital WDC WD1002FAEX-00Z3A0 ATA Device (SATA)
DTSOFT Virtual CdRom Device
Realtek High Definition Audio

Thank you all for posting useful information in this thread, guys! Cheers.
Daedalus023: So I recently got Neverwinter Nights Diamond off Gog, and I'm having some issues.

Everything seemed to run smoothly, until I finished creating my character. As soon as the intro cutscene started, the screen goes black and all I get is the audio. When I skip the cutscene, the screen continues to be black, except I can see my cursor.

Now the really interesting thing is, if I alt-tab out, then go back to the game, I suddenly get my visuals back and things seem to work fine. Still, I'd like to play the game normally without having to go through a process every time I cutscene plays.

My GPU is a Radeon R9 280X and my CPU is an intel i5-4690k. Anybody have a similar problem or any advice?
Forgot to add, I've already tried the SafeMovie=1 thing.
Evangelionobs: Go to your game directory right click nwnmain.exe go to properties -> compatibility then tick Disable desktop composition. your movies/cutscene's should work now.
Awesome, thx for the tip, this really helped
We have also had troubles getting it to work.

Only after downloading and installing the 1.69 hotfix mentioned by Jejerod, it works. The game as download from GOG was 1.69.8xx something already, but the patch did something to it for sure.

Now starting the individual movies from the main menu does not show them, but the blank black screen symptoms are gone.

We've also set the compatibility options for the program on the desktop to disable visual themes and to disable desktop composition, which was not enough to get the game working.
I know this is an old thread, but none of the solutions found on the internet worked for me and this is the first thread that pops up when googling this particular issue, so I thought I would list what I did to sorta semi-solve it for myself.

Every time I start the game, what I do is check to see if the issue is present by playing a video from the movies screen, and if it is, I just change the resolution. One might even be able to change it immediately back to their preferred resolution - just stay out of the options screen afterwards. Making ANY changes to the video settings causes the issue to reappear. If it reappears, I have to change the resolution again. Weird, but it works for me now. This probably won't help anyone but I thought I would post it just in case.
Post edited October 06, 2016 by Darkul81
Thank you @Jejerod !!!!!

I was having the issues, and downloaded the patch. It now works! Thank you!