It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Mine just crash without any apparent reason. I started a new game, and once I got out of the house, I walked a bit and the video drivers crashed, causing music from the game to loop in a strange way. The system recovered some 10 seconds later, however, and the game was still working. After a few minutes, it crashed again, and recovered. I just quit, tried again later, and it happened twice, and on the second one the game completely crashed.

Not sure why, but I guess it only happens outdoors.

Windows 7 Ultimate
i5 3570k
GTX 660 Ti

It's not overheating, and no way the game is too demanding.
This question / problem has been solved by olnortonimage
The latest nVidia drivers are causing problems for a lot of people. Roll back to an earlier version.
The newest ones are the 320.XX ones, right?

I didn't update to those, and still have the 314.XX drivers.
Yeah, I'm on 314.22, so that can't be the problem then. You reckon your card is not overheating, so check the physical connection of the card, and also check your PSU readings to make sure your power supply is not struggling/overloaded.
I'll give it a check, but I doubt that's the problem.

I mean, 2 days ago I was playing BF3 at high settings. Never had ANY trouble with any game, including the following: Miasmata, Natural Selection 2, Dishonored, Tomb Raider, Chivalry, among others. All of them at decently high settings.

I'll check out the drivers again, in case my PC updated without me noticing it <_<

Thanks for the help. You've had no trouble whatsoever with NWN2?

Edit: I just confirmed that I have the 314.22 drivers.
Post edited June 28, 2013 by Ars_Diaboli
Ars_Diaboli: You've had no trouble whatsoever with NWN2?
No. I'm currently playing BGR in the NWN2 engine, and that taxes it quite a bit. :)
Try reinstalling directx 9c & enabling v-sync makes NWN2 run much cooler on my system.
To whoever has a similar issue to mine, I just toned down some of the options in Advanced Graphics. Specifically, all three of them were lowered to "medium", and my AA was lowered from x4 to x2. The rest of them are all on high.

It's no longer crashing my video drivers, for whatever reason.

Edit: I also enabled V-Sync, like olnorton mentioned. I'm not sure which of the above is the one true reason for the fix, but I don't really feel like checking each one individually. Thank you, everyone.
Post edited June 29, 2013 by Ars_Diaboli