It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I wonder if any other non-WASD people have run across an issue that I just figured out. I'm a lefty so I use the numpad for movement options in games. I assign L/R to Num1 and Num3 (or End and PgDn). I ran through the intro level of the game just fine, no problems with any controls. When it opens me up into Martyr's End I started falling through the floor all the time! I tried redoing the intro level, to no avail.

I finally figured out what is going on. I think they left some debug keys activated in-game. When I hit End a lot of the game textures disappear, when I hit PgDn the lights disappear. So what was happening is that I was inadvertently turning off the floor textures when I was trying to strafe left!

Anyway, I can always use AutoHotkey to get around the problem for now. I was just curious to see whether anyone else has run into (or already discovered a fix) for this.
There is a patch (now up on GOG, was up last thing Friday on Steam). The notes mention about "Fix of Numpad keys triggering unexpected behaviours ingame", which might be a fix for this.

Just be aware that it's less of a patch and more redownload the whole blasted thing again before you update, if you are able to get it work for now and not having an issue with any of the other patched items.