It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
For those who are using 2160p monitors/televisions, you may have noticed that your cursor in-game is very small. I knew right away that this was a high DPI issue and to fix it, I navigated to GOG Galaxy/Games/Myst 3/residualvm, residualvm.exe (right-click), Properties, Compatibility, Change high DPI settings, and checked* the High DPI scaling override box at the bottom and selected System in the drop-down menu.

*At first this was greyed out for me, so in the main Compatibility menu, I had to select Change settings for all users at the bottom and return to Change high DPI settings.

Hope this helps someone!
avatar
DecafToaster: For those who are using 2160p monitors/televisions, you may have noticed that your cursor in-game is very small. I knew right away that this was a high DPI issue and to fix it, I navigated to GOG Galaxy/Games/Myst 3/residualvm, residualvm.exe (right-click), Properties, Compatibility, Change high DPI settings, and checked* the High DPI scaling override box at the bottom and selected System in the drop-down menu.

*At first this was greyed out for me, so in the main Compatibility menu, I had to select Change settings for all users at the bottom and return to Change high DPI settings.

Hope this helps someone!
Even on 1080p the cursor is tiny, so thank you for this! I have no doubt Cyan will patch it at some point. Might be worth getting word to them before they press the DVDs!
I did as you said and it didn't make any difference, did I need to restart the system or can I possibly have a different issue?

Dell P2715Q - 1920 x 1080
Dell E228WFP - 1680 x 1050
Alienware Area 51-alx i7 extreme
nVideia GeForce GTX980
12g ram

Windows Home 64

I also have Exile on my Surface Pro 3 running 2160 and it works fine?
I'm glad that it worked for you, Mataeus.

tbuchana, I know that you don't have to restart for the changes to take effect because I started up the game after making the changes and noticed that the cursor was much more visible. I'm not sure what other issue you could have that would prevent the changes from taking effect. The only requirement I could think of for changing the DPI scaling is Administrator privelages to select Change settings for all users in order to check the High DPI scaling override box if it was greyed out for you, but I imagine you would have figured that out.
Post edited July 13, 2018 by DecafToaster
avatar
DecafToaster: For those who are using 2160p monitors/televisions, you may have noticed that your cursor in-game is very small. I knew right away that this was a high DPI issue and to fix it, I navigated to GOG Galaxy/Games/Myst 3/residualvm, residualvm.exe (right-click), Properties, Compatibility, Change high DPI settings, and checked* the High DPI scaling override box at the bottom and selected System in the drop-down menu.

*At first this was greyed out for me, so in the main Compatibility menu, I had to select Change settings for all users at the bottom and return to Change high DPI settings.

Hope this helps someone!
Nice thought, and kind of you to post it. But it doesn't work for me. I've attached 2 groups of 3 screenshots each (reduced by 50% to allow upload). I'm trying to figure them out.

Upper screenshots, Applicaion DPI = 676x769 - 644x530 - 3840x2160
These are 3, side-by-side screenshots of 'residualvm.exe' Property sheet, 'residualvm.exe' running on its own, and "Myst Exile". All look as expected.

Lower screenshots, System DPI = 676x769 - 1284x1014 - 1920x1080
These are the 3, side-by-side screenshots when the 'residualvm.exe' is set to System DPI. There's some strangeness. Things are indeed bigger, but look at "Myst Exile"... It's not scaled properly, and it's only the southwest quarter (i.e., 1920x1080) of what it should be (that is then scaled up for the display, but obviously not scaled up for the screenshot). Imagine the "Myst Exile" scaled up to 3840x2160 (to be the same size as the Upper screenshot). That's what's actually seen. Note the mouse pointer (finger). When "Myst Exile" is scaled up to 3840x2160, it winds up being 4 times the size of the (almost invisible) finger in the Upper screenshot. That would be fine, but I couldn't get the end of the finger on screen. Also, there's the obvious problem that 3-quarters of the "Myst Exile" image is missing.

I've tried several different strategies, but nothing's worked. I think the problem is that 'resiualvm.exe' is doing one thing, and Windows (v.10-1803) is fighting.

Got any more bright ideas?
Warm Regards,
Mark.

UPDATE: I found 2 INI-files!!!
c:\Users\acer\AppData\Roaming\ResidualVM\residualvm.ini
c:\GOG Games\Myst 3\myst3.ini
There are some conflicts.
Attachments:
Post edited September 04, 2018 by markfilipak
avatar
DecafToaster: GOG Galaxy/Games/Myst 3/residualvm, residualvm.exe (right-click), Properties, Compatibility, Change high DPI settings, and checked* the High DPI scaling override box at the bottom and selected System in the drop-down menu.
My first problem is that when I get to the Compatibility tab, there is no button or section labeled "Change high DPI settings." The closest thing I see is a checkbox labeled "Disable display scaling on high DPI settings" (see attached image). If I have that checked or unchecked it makes no difference. Help?
Attachments: