It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

The game seems to be running smoothly enough, however certain walls are transparent where they shouldn't be. is the best example.

Running on:
GPU: GTX 970
CPU: i7-950

OS: Windows 7 64bit

disabling alpha blending doesn't seem to work sadly, and software mode makes the game chug terribly whenever particle effects are on screen.
Launch with D3D, but turn it off in the options menu. It'll run in software without the slowdown.