It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I'm experiencing an annoying problem with Moto Racer 1 when running it with D3D mode. It's a graphics glitch that looks like strobe lighting (best way I can describe it) coming from the top-left corner of the screen and spreading out. These strobe-like artefacts constantly flicker and move. It happens on the Name-Entry screen, when I'm selecting a bike and also during the races themselves.

I'm using Windows 8.1 (64Bit), Intel Integrated chipset.

Any help would be much appreciated as I've tried a few things from these forums to no avail so-far.
Attachments:
Post edited June 05, 2017 by RetroCodger426
No posts in this topic were marked as the solution yet. If you can help, add your reply
Try Changeing the Z buffer and Alpha Blending mode options that pop up when you launch the game.
Hi and thanks for replying. I've tried both of those as well as many other manual options. I've also tried the usual running as admin+compatibility options. I even tried various settings using the Microsoft Application Compatibility Toolkit, as well as other glide wrappers...

Sadly, none of those fixed this problem.

I contacted GOG Support and they said it could be insufficient cooling or (if I remember correctly) a driver or Direct X problem. I've never had this problem with any other games and my drivers are up-to-date, and I have the necessary runtimes. They also suggested running it in a clean boot environment; I tried that, but the problem was still there.

It seems like this game just doesn't like my setup. I can play in software mode and it's very smooth with the 60fps option under manual settings; at least that is to say it's smooth up until I brake, race in snow, or do anything that causes dust and smoke and the likes to appear.
Post edited June 12, 2017 by RetroCodger426
avatar
RetroCodger426: I contacted GOG Support and they said it could be insufficient cooling or (if I remember correctly) a driver or Direct X problem. I've never had this problem with any other games and my drivers are up-to-date, and I have the necessary runtimes.
Sounds like a driver issue to me. You could try older drivers as you are already presumably up-to-date.
Post edited June 13, 2017 by Gydion
avatar
RetroCodger426: I contacted GOG Support and they said it could be insufficient cooling or (if I remember correctly) a driver or Direct X problem. I've never had this problem with any other games and my drivers are up-to-date, and I have the necessary runtimes.
avatar
Gydion: Sounds like a driver issue to me. You could try older drivers as you are already presumably up-to-date.
Sorry for this late reply. I've been trying to post this, but it's been acting up.

That's a good idea and it makes sense to me, so I had some hope that it might just work. Sadly, it didn't. After reading your comment I tried the oldest driver I could find from ... I think it was ... 2012, but no joy; still the same.
I think I'll try it with all the appropriate drivers I can find because you never know, one of them might just do the trick. It's worth a shot anyway.

Thanks for the effort all the same, Gydion.

p.s. Nearly forgot. On the upside (could be my imagination, but) this older driver seems to have improved performance issues on one or two other games.