It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
First of all: The accepted solution in another thread did not work - but since it's marked as "SOLVED" I rather open a new one.

Now to the problem: Moto Racer 2 changes the resolution, creates a black screen for about a second and shuts down immediately afterwards, so I crash to desktop.

I tried different manual start parameters (like the keepvram stuff) but nothing worked. MR2 always does the same - only the delphine.err varies a bit.


Any help please? I can't play this game, no matter what I do. System specs:

Windows 7 64bit
nVidia / EVGA GTX 570hd
ASUS P5WDG2-WS (Intel(R) 82801GB/GR (ICH7 Family))
Intel Core2Duo E6600
8gb ram
-2gb QSoft Enterprise ram drive
Adaptec RAID 31205

Here's my delphine.err when running without manual settings:



Infos, errors and warnings occured during MotoRacer 2 :
---------------------------------------------------------------------------------
Cpu detected : Intel Pentium(R) II
Vendor ID : GenuineIntel
Nb CPUID functions : 0x0000000a
Cpu signature : 0x000006f6 (0000 0000 0000 0000 0000 0110 1111 0110)
Cpu features : 0xbfebfbff (1011 1111 1110 1011 1111 1011 1111 1111)
Raw Cpu frequency : 2419 Mhz
Normalised Cpu frequency : 2419 Mhz
System : Windows(R) NT
Windows Available memory : 4 294 967 295 bytes
---------------------------------------------------------------------------------
(!) Windowed mode forbiden because desktop n.b.p.p is 32
generic optimisations used


--------------------------------------------------------------
(i) Memory detected : Txt:-40939520 Primary:1309081600 Total:-33259520 Blended:No FullScreen:Yes Res:640x480 (BackBuffer not created yet!)
(i) Memory used : Screen:-6451200 Textures:0
(!) INCORRECT VRAM PARAMETERS!
--------------------------------------------------------------

Cannot initialise screen mode
Post edited June 23, 2012 by vertex
No posts in this topic were marked as the solution yet. If you can help, add your reply
I had this same problem on Win 7 (but not on XP). The only way to get rid of it that worked for me was to simply uncheck the Direct3D option in the launcher. The game doesn't look as nice, but it does run.
Sadly that doesn't work for me either :(

With unchecking the Direct3D box I only get the title screen with a mouse cursor - and when it "fades" out, the game crashes to desktop again with Win7 telling me "has stopped working".

Running as administrator doesn't make a difference.
I found a solve on Win 7 x64 :
Make a shorcut of file moto.exe in the folder of Motoracer 2,
edit the properties and add this in the target box:

-d3d -KeepAvailableVram1073741824

Also add -fr if you are french or other languages -sw, -sp, -it, -gr, -us.
(for Skip intro add -SkipIntro) apply and gooooooooo !

:-)
Post edited December 02, 2012 by neoyan
avatar
vertex: First of all: The accepted solution in another thread did not work - but since it's marked as "SOLVED" I rather open a new one.

Now to the problem: Moto Racer 2 changes the resolution, creates a black screen for about a second and shuts down immediately afterwards, so I crash to desktop.

I tried different manual start parameters (like the keepvram stuff) but nothing worked. MR2 always does the same - only the delphine.err varies a bit.

Any help please? I can't play this game, no matter what I do. System specs:

Windows 7 64bit
nVidia / EVGA GTX 570hd
ASUS P5WDG2-WS (Intel(R) 82801GB/GR (ICH7 Family))
Intel Core2Duo E6600
8gb ram
-2gb QSoft Enterprise ram drive
Adaptec RAID 31205

Here's my delphine.err when running without manual settings:

Infos, errors and warnings occured during MotoRacer 2 :
---------------------------------------------------------------------------------
Cpu detected : Intel Pentium(R) II
Vendor ID : GenuineIntel
Nb CPUID functions : 0x0000000a
Cpu signature : 0x000006f6 (0000 0000 0000 0000 0000 0110 1111 0110)
Cpu features : 0xbfebfbff (1011 1111 1110 1011 1111 1011 1111 1111)
Raw Cpu frequency : 2419 Mhz
Normalised Cpu frequency : 2419 Mhz
System : Windows(R) NT
Windows Available memory : 4 294 967 295 bytes
---------------------------------------------------------------------------------
(!) Windowed mode forbiden because desktop n.b.p.p is 32
generic optimisations used

--------------------------------------------------------------
(i) Memory detected : Txt:-40939520 Primary:1309081600 Total:-33259520 Blended:No FullScreen:Yes Res:640x480 (BackBuffer not created yet!)
(i) Memory used : Screen:-6451200 Textures:0
(!) INCORRECT VRAM PARAMETERS!
--------------------------------------------------------------

Cannot initialise screen mode
I think I found a solution to this video problem on how to get Moto Racer 2's Direct3D mode to work with Windows 7. When a user checks their "delphine.err" file in the game's "data" folder, a lot of times the "Memory used" section will have a negative number such as "-6451200" and then say "(!) INCORRECT VRAM PARAMETERS!"

It looks like the game is misinterpreting the total amount of RAM on the computer and gets a negative number instead of a positive one. So my solution was to enter a negative VRam number in the parameters in the GOG Launcher. To try this fix, click on the on the default Moto Racer 2 Launcher, make sure DirectX 3D is selected and then select "Manual Settings." In the new window enter this:
-D3D -KeepAvailableVram-1073741824 -skipintro

Notice that the "-KeepAvailableVram" value is a negative number. If this doesn't work for you, try using a negative number that's either higher or lower. Hope this helps!
avatar
vertex: First of all: The accepted solution in another thread did not work - but since it's marked as "SOLVED" I rather open a new one.

Now to the problem: Moto Racer 2 changes the resolution, creates a black screen for about a second and shuts down immediately afterwards, so I crash to desktop.

I tried different manual start parameters (like the keepvram stuff) but nothing worked. MR2 always does the same - only the delphine.err varies a bit.

Any help please? I can't play this game, no matter what I do. System specs:

Windows 7 64bit
nVidia / EVGA GTX 570hd
ASUS P5WDG2-WS (Intel(R) 82801GB/GR (ICH7 Family))
Intel Core2Duo E6600
8gb ram
-2gb QSoft Enterprise ram drive
Adaptec RAID 31205

Here's my delphine.err when running without manual settings:

Infos, errors and warnings occured during MotoRacer 2 :
---------------------------------------------------------------------------------
Cpu detected : Intel Pentium(R) II
Vendor ID : GenuineIntel
Nb CPUID functions : 0x0000000a
Cpu signature : 0x000006f6 (0000 0000 0000 0000 0000 0110 1111 0110)
Cpu features : 0xbfebfbff (1011 1111 1110 1011 1111 1011 1111 1111)
Raw Cpu frequency : 2419 Mhz
Normalised Cpu frequency : 2419 Mhz
System : Windows(R) NT
Windows Available memory : 4 294 967 295 bytes
---------------------------------------------------------------------------------
(!) Windowed mode forbiden because desktop n.b.p.p is 32
generic optimisations used

--------------------------------------------------------------
(i) Memory detected : Txt:-40939520 Primary:1309081600 Total:-33259520 Blended:No FullScreen:Yes Res:640x480 (BackBuffer not created yet!)
(i) Memory used : Screen:-6451200 Textures:0
(!) INCORRECT VRAM PARAMETERS!
--------------------------------------------------------------

Cannot initialise screen mode
avatar
IronArcturus: I think I found a solution to this video problem on how to get Moto Racer 2's Direct3D mode to work with Windows 7. When a user checks their "delphine.err" file in the game's "data" folder, a lot of times the "Memory used" section will have a negative number such as "-6451200" and then say "(!) INCORRECT VRAM PARAMETERS!"

It looks like the game is misinterpreting the total amount of RAM on the computer and gets a negative number instead of a positive one. So my solution was to enter a negative VRam number in the parameters in the GOG Launcher. To try this fix, click on the on the default Moto Racer 2 Launcher, make sure DirectX 3D is selected and then select "Manual Settings." In the new window enter this:
-D3D -KeepAvailableVram-1073741824 -skipintro

Notice that the "-KeepAvailableVram" value is a negative number. If this doesn't work for you, try using a negative number that's either higher or lower. Hope this helps!
Not sure about OP but this got the game running in Direct3D for me! thank you!!!
Got working now, thanks so much :)

It looks like the game is misinterpreting the total amount of RAM on the computer and gets a negative number instead of a positive one. So my solution was to enter a negative VRam number in the parameters in the GOG Launcher. To try this fix, click on the on the default Moto Racer 2 Launcher, make sure DirectX 3D is selected and then select "Manual Settings." In the new window enter this:
-D3D -KeepAvailableVram-1073741824 -skipintro

Notice that the "-KeepAvailableVram" value is a negative number. If this doesn't work for you, try using a negative number that's either higher or lower. Hope this helps!
Thanks, this did the trick, now the game looks amazingly better!
avatar
vertex: First of all: The accepted solution in another thread did not work - but since it's marked as "SOLVED" I rather open a new one.

Now to the problem: Moto Racer 2 changes the resolution, creates a black screen for about a second and shuts down immediately afterwards, so I crash to desktop.

I tried different manual start parameters (like the keepvram stuff) but nothing worked. MR2 always does the same - only the delphine.err varies a bit.

Any help please? I can't play this game, no matter what I do. System specs:

Windows 7 64bit
nVidia / EVGA GTX 570hd
ASUS P5WDG2-WS (Intel(R) 82801GB/GR (ICH7 Family))
Intel Core2Duo E6600
8gb ram
-2gb QSoft Enterprise ram drive
Adaptec RAID 31205

Here's my delphine.err when running without manual settings:

Infos, errors and warnings occured during MotoRacer 2 :
---------------------------------------------------------------------------------
Cpu detected : Intel Pentium(R) II
Vendor ID : GenuineIntel
Nb CPUID functions : 0x0000000a
Cpu signature : 0x000006f6 (0000 0000 0000 0000 0000 0110 1111 0110)
Cpu features : 0xbfebfbff (1011 1111 1110 1011 1111 1011 1111 1111)
Raw Cpu frequency : 2419 Mhz
Normalised Cpu frequency : 2419 Mhz
System : Windows(R) NT
Windows Available memory : 4 294 967 295 bytes
---------------------------------------------------------------------------------
(!) Windowed mode forbiden because desktop n.b.p.p is 32
generic optimisations used

--------------------------------------------------------------
(i) Memory detected : Txt:-40939520 Primary:1309081600 Total:-33259520 Blended:No FullScreen:Yes Res:640x480 (BackBuffer not created yet!)
(i) Memory used : Screen:-6451200 Textures:0
(!) INCORRECT VRAM PARAMETERS!
--------------------------------------------------------------

Cannot initialise screen mode
avatar
IronArcturus: I think I found a solution to this video problem on how to get Moto Racer 2's Direct3D mode to work with Windows 7. When a user checks their "delphine.err" file in the game's "data" folder, a lot of times the "Memory used" section will have a negative number such as "-6451200" and then say "(!) INCORRECT VRAM PARAMETERS!"

It looks like the game is misinterpreting the total amount of RAM on the computer and gets a negative number instead of a positive one. So my solution was to enter a negative VRam number in the parameters in the GOG Launcher. To try this fix, click on the on the default Moto Racer 2 Launcher, make sure DirectX 3D is selected and then select "Manual Settings." In the new window enter this:
-D3D -KeepAvailableVram-1073741824 -skipintro

Notice that the "-KeepAvailableVram" value is a negative number. If this doesn't work for you, try using a negative number that's either higher or lower. Hope this helps!
Wow, this is the only advice that works. You da man!
avatar
vertex: First of all: The accepted solution in another thread did not work - but since it's marked as "SOLVED" I rather open a new one.

Now to the problem: Moto Racer 2 changes the resolution, creates a black screen for about a second and shuts down immediately afterwards, so I crash to desktop.

I tried different manual start parameters (like the keepvram stuff) but nothing worked. MR2 always does the same - only the delphine.err varies a bit.

Any help please? I can't play this game, no matter what I do. System specs:

Windows 7 64bit
nVidia / EVGA GTX 570hd
ASUS P5WDG2-WS (Intel(R) 82801GB/GR (ICH7 Family))
Intel Core2Duo E6600
8gb ram
-2gb QSoft Enterprise ram drive
Adaptec RAID 31205

Here's my delphine.err when running without manual settings:

Infos, errors and warnings occured during MotoRacer 2 :
---------------------------------------------------------------------------------
Cpu detected : Intel Pentium(R) II
Vendor ID : GenuineIntel
Nb CPUID functions : 0x0000000a
Cpu signature : 0x000006f6 (0000 0000 0000 0000 0000 0110 1111 0110)
Cpu features : 0xbfebfbff (1011 1111 1110 1011 1111 1011 1111 1111)
Raw Cpu frequency : 2419 Mhz
Normalised Cpu frequency : 2419 Mhz
System : Windows(R) NT
Windows Available memory : 4 294 967 295 bytes
---------------------------------------------------------------------------------
(!) Windowed mode forbiden because desktop n.b.p.p is 32
generic optimisations used

--------------------------------------------------------------
(i) Memory detected : Txt:-40939520 Primary:1309081600 Total:-33259520 Blended:No FullScreen:Yes Res:640x480 (BackBuffer not created yet!)
(i) Memory used : Screen:-6451200 Textures:0
(!) INCORRECT VRAM PARAMETERS!
--------------------------------------------------------------

Cannot initialise screen mode
I know this is an old thread, but your best bet at getting this game to run would be to use dgvodoo and read the readme about using its Direct X wrapper. Doing this allowed me to get the game working. My system specs are below:

OS: Microsoft Windows 10 Pro (64-bit)
Processor: AMD Phenom II X6 1045T @ 2.70 GHz
System RAM: 16.00 GB
Video Memory: 4.00 GB
Video Adapter Name: NVIDIA GeForce GTX 960
avatar
IronArcturus: I think I found a solution to this video problem on how to get Moto Racer 2's Direct3D mode to work with Windows 7. When a user checks their "delphine.err" file in the game's "data" folder, a lot of times the "Memory used" section will have a negative number such as "-6451200" and then say "(!) INCORRECT VRAM PARAMETERS!"

It looks like the game is misinterpreting the total amount of RAM on the computer and gets a negative number instead of a positive one. So my solution was to enter a negative VRam number in the parameters in the GOG Launcher. To try this fix, click on the on the default Moto Racer 2 Launcher, make sure DirectX 3D is selected and then select "Manual Settings." In the new window enter this:
-D3D -KeepAvailableVram-1073741824 -skipintro

Notice that the "-KeepAvailableVram" value is a negative number. If this doesn't work for you, try using a negative number that's either higher or lower. Hope this helps!
avatar
johntan404: Wow, this is the only advice that works. You da man!
Thanks, I wanted to try the game today and after nearly pulling my hair out, I checked here and what you posted worked.
avatar
vertex: First of all: The accepted solution in another thread did not work - but since it's marked as "SOLVED" I rather open a new one.

Now to the problem: Moto Racer 2 changes the resolution, creates a black screen for about a second and shuts down immediately afterwards, so I crash to desktop.

I tried different manual start parameters (like the keepvram stuff) but nothing worked. MR2 always does the same - only the delphine.err varies a bit.

Any help please? I can't play this game, no matter what I do. System specs:

Windows 7 64bit
nVidia / EVGA GTX 570hd
ASUS P5WDG2-WS (Intel(R) 82801GB/GR (ICH7 Family))
Intel Core2Duo E6600
8gb ram
-2gb QSoft Enterprise ram drive
Adaptec RAID 31205

Here's my delphine.err when running without manual settings:

Infos, errors and warnings occured during MotoRacer 2 :
---------------------------------------------------------------------------------
Cpu detected : Intel Pentium(R) II
Vendor ID : GenuineIntel
Nb CPUID functions : 0x0000000a
Cpu signature : 0x000006f6 (0000 0000 0000 0000 0000 0110 1111 0110)
Cpu features : 0xbfebfbff (1011 1111 1110 1011 1111 1011 1111 1111)
Raw Cpu frequency : 2419 Mhz
Normalised Cpu frequency : 2419 Mhz
System : Windows(R) NT
Windows Available memory : 4 294 967 295 bytes
---------------------------------------------------------------------------------
(!) Windowed mode forbiden because desktop n.b.p.p is 32
generic optimisations used

--------------------------------------------------------------
(i) Memory detected : Txt:-40939520 Primary:1309081600 Total:-33259520 Blended:No FullScreen:Yes Res:640x480 (BackBuffer not created yet!)
(i) Memory used : Screen:-6451200 Textures:0
(!) INCORRECT VRAM PARAMETERS!
--------------------------------------------------------------

Cannot initialise screen mode
avatar
coates32: I know this is an old thread, but your best bet at getting this game to run would be to use dgvodoo and read the readme about using its Direct X wrapper. Doing this allowed me to get the game working. My system specs are below:

OS: Microsoft Windows 10 Pro (64-bit)
Processor: AMD Phenom II X6 1045T @ 2.70 GHz
System RAM: 16.00 GB
Video Memory: 4.00 GB
Video Adapter Name: NVIDIA GeForce GTX 960
This works for me! I'm on Windows 7 but finally I fixed that problem by using dgVoodoo. I had negative values on the delphin.err too, but on the "Memory detected" attribute and not on the "Memory used" one. dgVoodoo solved that.

In dgVoodoo is possible to assing VRAM maually, so I selected a value and deleted the "KeepAvailableVram" paramenter from the .ini file, because that value was higher than the dgVoodoo assigned memory, so that was keeping my game crashing.

Probably it could work by lowering the KeepAvailableVram value too and not just by deleting it.

Now my D3D is working fine!
avatar
vertex: First of all: The accepted solution in another thread did not work - but since it's marked as "SOLVED" I rather open a new one.

Now to the problem: Moto Racer 2 changes the resolution, creates a black screen for about a second and shuts down immediately afterwards, so I crash to desktop.

I tried different manual start parameters (like the keepvram stuff) but nothing worked. MR2 always does the same - only the delphine.err varies a bit.

Any help please? I can't play this game, no matter what I do. System specs:

Windows 7 64bit
nVidia / EVGA GTX 570hd
ASUS P5WDG2-WS (Intel(R) 82801GB/GR (ICH7 Family))
Intel Core2Duo E6600
8gb ram
-2gb QSoft Enterprise ram drive
Adaptec RAID 31205

Here's my delphine.err when running without manual settings:

Infos, errors and warnings occured during MotoRacer 2 :
---------------------------------------------------------------------------------
Cpu detected : Intel Pentium(R) II
Vendor ID : GenuineIntel
Nb CPUID functions : 0x0000000a
Cpu signature : 0x000006f6 (0000 0000 0000 0000 0000 0110 1111 0110)
Cpu features : 0xbfebfbff (1011 1111 1110 1011 1111 1011 1111 1111)
Raw Cpu frequency : 2419 Mhz
Normalised Cpu frequency : 2419 Mhz
System : Windows(R) NT
Windows Available memory : 4 294 967 295 bytes
---------------------------------------------------------------------------------
(!) Windowed mode forbiden because desktop n.b.p.p is 32
generic optimisations used

--------------------------------------------------------------
(i) Memory detected : Txt:-40939520 Primary:1309081600 Total:-33259520 Blended:No FullScreen:Yes Res:640x480 (BackBuffer not created yet!)
(i) Memory used : Screen:-6451200 Textures:0
(!) INCORRECT VRAM PARAMETERS!
--------------------------------------------------------------

Cannot initialise screen mode
Setting like the attatchment pic , In the GOG Galaxy client --> setting -->add command line parameter-->
add: -d3d -KeepAvailableVram1073741824

The Game runs . May this will help you.
Attachments:
moto.png (274 Kb)
Post edited October 23, 2018 by akbot48