It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm encountering a bug where the loading screen does not progress. I've submitted the bug to the developer, but thought I would share my "work around" in case any one else experiences it in the mean time.

NOTE: I am running an unsupported OS that may be the cause (I haven't tested this yet).
Manjaro 15.12 64-bit with proprietary AMD drivers.

Work around (Linux):
Tab out of the game, and open the terminal.
Run ps -aux | grep Moon to find the two Moon Hunter processes.
Run kill xxxx (where xxxx is the largest process number for Moon Hunter).
Game should load to 100%. If not, repeat once more.

I suppose this could work for Windows, Mac by using the Task Manager, etc. I just haven't tried it.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Installed Ubuntu 14.04, and the loading delay does not happen there (in the 4 times I ran it).

Not clear why it happens in Manjaro (no error messages in terminal).
I just have to assume it's an updated library/something that is causing the issue.