It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I used the language setup tool and set it to English, but the game starts in German anyway. How can I fix this?
This question / problem has been solved by Cypersimage
I have the same problem. Windows 10 x64, launching language changer as admin, language wont change. And i can`t log into my ttg account, it`s says i already signed in, but i not entered login/pass to log into my account. Please help me;)
You need to change region in the OS settings and then it should work.
Control Panel -> Clock, Language and Region -> Region and Language -> Administrative tab -> Current language for non-Unicode programs.
Why is there an option to change the language setting when this option is then ignored?

I don't want to change the region settings of my computer, I just want to play the game in a language of my choice. It works with other games.
Post edited February 18, 2018 by moronoxyd