It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

First of all, I love this game so far. After reading some reviews I found online I started playing with mixed feelings, but I've been pleasantly surprised to find the game quite enjoyable. I really love how the towns evolve, and how new quests appear depending on your progress, something that was missing from World of Xeen. That said, I haven't really gone far yet, but I hope my impression of the game doesn't change.

Anyway, 2 Qs:

1) What does the fountain in Hart do? I think I restored the town completely but the fountain still does nothing (I get the cool and refreshing generic message).

2) When do I start getting taxes? I think a few weeks have passed, but the chest in fron of bank still tells me no taxes have been collected.

This question / problem has been solved by Mentalepsyimage
1) The fountain does nothing, as far as I ever saw.

2) I received taxes maybe twice over the entire game. I think it's broken. Don't worry too much about it, though. Unlike many of the other M&M games, you'll run out of experience points long before you run out of gold.
Thanks. No taxes and I've already cleared Sand Town. Still not really an issue though.

Really enjoying this game, much better than what I expected after the reviews. Didn't have to use the "jump back and attack" technique even once :) Bugs are there but nothing game-breaking. Sloppy grammar and punctuation is slightly annoying since it's something that could have been fixed easily. Still really great game.
Found a walkthrough that says the well in Hart cures disease. Haven't tested it since up till now haven't found a way to get disease...

EDIT: I found a way to get disease: you can do it in Hart dungeon itself, by searching bodies. And the fountain does indeed cure it!

EDIT2: Wow, after like a zillion years, finally taxes appeared in Hart once. Not sure what triggered it, but it didn't seem to be time, because I reloaded a previous save, rested till same amount of time passed and this time no taxes were there.
Post edited October 15, 2013 by ZFR