It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I tried running the game from the Gog Galaxy 2.0 and just using the .exe files. Both ways result in a little black rectangle being shown for a few seconds on the screen and then disappearing -- that's it.

My specs are:
- Gog's version of Might and Magic 9
- Windows 10 64bit
- latest nVidia drivers for my 1080Ti
- both lithtech.exe and mm9.exe set to "Disable full-screen optimisations" and "Run this program as an administrator"
- my dxcfg.exe has everything set to default.

I tried setting the compatibility mode to Windows XP SP 2 and 3, Win 7 but the result was always the same.
I also tried Mok's cshell.dll file but there's no difference, either.

Could I get any help?
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
KurakDarcia: I tried running the game from the Gog Galaxy 2.0 and just using the .exe files. Both ways result in a little black rectangle being shown for a few seconds on the screen and then disappearing -- that's it.

My specs are:
- Gog's version of Might and Magic 9
- Windows 10 64bit
- latest nVidia drivers for my 1080Ti
- both lithtech.exe and mm9.exe set to "Disable full-screen optimisations" and "Run this program as an administrator"
- my dxcfg.exe has everything set to default.

I tried setting the compatibility mode to Windows XP SP 2 and 3, Win 7 but the result was always the same.
I also tried Mok's cshell.dll file but there's no difference, either.

Could I get any help?
Mine runs as best as it can on Windows 10 x64.
I have no compatibility settings on either mm9.exe or lithtech.exe.
In the "Additional executables" section under the game in GoG Galaxy there should be a DirectX settings.
All those on mine are "Defaults" except Display Mode is "Same as Desktop" and Scaling Method is "Integer". The latter would probably be personal preference. Integer does keep the 4:3 ratio game was designed for.
Using the "Settings" under Additional executables, 3D sound I have off (it was buggy back in the day for most games anyways). Advanced, all on left unchecked, all on right checked.

Note: Use lots of saves. Multiple ones, not just saving over. This game was buggy/unfinished when released and corrupted saves was common. Plus, it will crash to desktop during play at times. Even with fixes out there that are supposed to fix. And it does have the big fan made TELP 1.3 fixes included already.

There is also dgVoodoo, which can replace the ddraw.dll in the games folder as well. Though the "DirectX Settings" seems to be some alternative similar to dgVoodoo.
avatar
zandrag: Mine runs as best as it can on Windows 10 x64.
I have no compatibility settings on either mm9.exe or lithtech.exe.
In the "Additional executables" section under the game in GoG Galaxy there should be a DirectX settings.
All those on mine are "Defaults" except Display Mode is "Same as Desktop" and Scaling Method is "Integer". The latter would probably be personal preference. Integer does keep the 4:3 ratio game was designed for.
Using the "Settings" under Additional executables, 3D sound I have off (it was buggy back in the day for most games anyways). Advanced, all on left unchecked, all on right checked.

Note: Use lots of saves. Multiple ones, not just saving over. This game was buggy/unfinished when released and corrupted saves was common. Plus, it will crash to desktop during play at times. Even with fixes out there that are supposed to fix. And it does have the big fan made TELP 1.3 fixes included already.

There is also dgVoodoo, which can replace the ddraw.dll in the games folder as well. Though the "DirectX Settings" seems to be some alternative similar to dgVoodoo.
Thank you for your tips, zandrag.

I've set everything exactly as you said, i.e. no compatibility, "Display mode same as desktop" and "Scaling Method: Integer".
I also checked the "Settings" and my 3D sound was off and the "Advanced" were all the same as yours.
Unfortunately, it still doesn't work :(
avatar
KurakDarcia: Thank you for your tips, zandrag.

I've set everything exactly as you said, i.e. no compatibility, "Display mode same as desktop" and "Scaling Method: Integer".
I also checked the "Settings" and my 3D sound was off and the "Advanced" were all the same as yours.
Unfortunately, it still doesn't work :(
I have done so much on my computer for getting legacy games to work since XP was the OS, I lose track of everything.
Another thought:

Make sure you have DirectPlay installed?
PC Settings -> Apps & Features -> Optional features -> on right top "More Windows features"

Under Legacy Components in the small window that pops up should be a DirectPlay. Check that and hit OK.
avatar
zandrag: Make sure you have DirectPlay installed?
PC Settings -> Apps & Features -> Optional features -> on right top "More Windows features"

Under Legacy Components in the small window that pops up should be a DirectPlay. Check that and hit OK.
Yeah, I googled that yesterday and looked it up on my system but it's been on :(
Right, ok!
I wrote about this to Gog's support and they actually managed to help me out so I'm now gonna detail the solution here in case someone else might have the same problem in the future.

I was asked to provide a report from DxDiag. You can run this if you type "dxdiag" in Windows's start menu; once it's finished gathering data on your setup, it can save a .txt file with a report. Do it.
Open the file afterwards and search for "lithtech.exe" (it's the executable for MM9).

In my case there were a few error reports for lithtech.exe and all of them detailed "DINPUT.dll". The people from support reckoned it's a problem with one of my input peripherals so I started disconnecting them one by one and checking if the game'll start.

It turned out that's exactly what happened -- I disconnected my SteelSeries Siberia P800 headset and suddenly the game just ran.

I'm extremely grateful to the people in Gog's game support and to @zandrag as well: thank you for your help :)
avatar
KurakDarcia: Right, ok!
I wrote about this to Gog's support and they actually managed to help me out so I'm now gonna detail the solution here in case someone else might have the same problem in the future.

I was asked to provide a report from DxDiag. You can run this if you type "dxdiag" in Windows's start menu; once it's finished gathering data on your setup, it can save a .txt file with a report. Do it.
Open the file afterwards and search for "lithtech.exe" (it's the executable for MM9).

In my case there were a few error reports for lithtech.exe and all of them detailed "DINPUT.dll". The people from support reckoned it's a problem with one of my input peripherals so I started disconnecting them one by one and checking if the game'll start.

It turned out that's exactly what happened -- I disconnected my SteelSeries Siberia P800 headset and suddenly the game just ran.

I'm extremely grateful to the people in Gog's game support and to @zandrag as well: thank you for your help :)
LOL! I have the same headset and the same problem. I can play MM9 again now.Thanks!

EDIT:
Switching the input to AUX on the transmitter box and connecting a standard mini jack between my PC and the box allows me to play MM9 with the headset.
Post edited December 01, 2020 by Lars_Rakett
avatar
KurakDarcia: Right, ok!
I wrote about this to Gog's support and they actually managed to help me out so I'm now gonna detail the solution here in case someone else might have the same problem in the future.

I was asked to provide a report from DxDiag. You can run this if you type "dxdiag" in Windows's start menu; once it's finished gathering data on your setup, it can save a .txt file with a report. Do it.
Open the file afterwards and search for "lithtech.exe" (it's the executable for MM9).

In my case there were a few error reports for lithtech.exe and all of them detailed "DINPUT.dll". The people from support reckoned it's a problem with one of my input peripherals so I started disconnecting them one by one and checking if the game'll start.

It turned out that's exactly what happened -- I disconnected my SteelSeries Siberia P800 headset and suddenly the game just ran.

I'm extremely grateful to the people in Gog's game support and to @zandrag as well: thank you for your help :)
Thanks for the investigation and solution.

Disconnecting my headset (Logitech G533 Bluetooth wireless) allowed the game to start for me.

I was also in an earlier thread about this topic and posted your solution over there, giving you named credit.
Again, Thank You.
Post edited December 12, 2020 by LesTyebe