It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Using Ubuntu 20.04, wine-4.0-rc2, nvidia-driver-470 (although this problem has persisted through several wine, driver, and even OS updates).

The mobile character meshes are invisible and the textures behave bizarrely, as though they were projected onto the nearby walls.

(I took a video and uploaded it to Youtube but I'm having trouble posting the link.)

EDIT: I also intended to mark this as a question/problem but that apparently didn't happen.
Post edited September 25, 2021 by protondonor
protondonor: (I took a video and uploaded it to Youtube but I'm having trouble posting the link.)
Your rep is too low to post links. How about just the video ID?

Note that I have had no problems with this game's graphics with wine-3 through wine-6, but I haven't done much more than test if the game even works.
Thanks, the video ID is PnMNYwH1arE.
protondonor: Thanks, the video ID is PnMNYwH1arE.
You know, I do vaguely recall seeing something like that in the distant past, but it works perfectly now. When you say "persisted through several wine update", do you mean earlier than 4.0rc2, or later? I can no longer run the game with wine-3 (crashes when entering 3D mode), but wine-4.0.4 and wine-6.0.3 work fine. I can't get wine-4 to fail, no matter what weird stuff I do.

Are you using a fresh prefix for this game? Are you using some alternate utility to install, which might enable some library overrides? I have my standard set of overrides enabled usually, but the game works fine without (and doesn't use any of the overrides I set, anyway). I also explicitly set csmt to on, although I also set it to ff without issue.

Do you launch via mm9.exe, or via lithtech.exe? Did you try playing with the video options in mm9.exe?
I mean earlier than 4.0-rc2, haven't tried later.

I don't think I've tried a fresh prefix yet; I'll try that when I have time later today.

This happens when launching either via mm9.exe or lithtech.exe. I have not tried all 16 possible video options but I have played with them a bit to no avail.
I can confirm that it still occurs on a clean (32-bit) wineprefix, installed via just running wine against the .exe download from GOG.
Post edited September 26, 2021 by protondonor