It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Starting MM1, my first time for any MM series game. Was stunned at how bad the graphics looked at first and the difficulty of the interface, even though I'm used to playing roguelikes etc. But really enjoying it now that I'm into it. Even enjoying doing my own mapping.

I've taken the vellum scroll to Erliquin, found Agar's secret location, checked that I have the vellum scroll in party inventory, but he tells me he has no use for me. Not sure what I could have done wrong, or whether I can continue to play the game, completing later quests without completing this quest. Having googled a quest list I get the impression this quest is the start of the main quest line, but didn't want to spoil myself by detailed reading of what follows after.
That's odd... the only thing I can think of is to make sure that your party leader (the character in spot 1) is the one carrying the vellum scroll. If that doesn't work, something you could try (make sure you save your game first) is to drop the scroll, then go back to the caves under Sorpigal and meet the wizard again. He should give you another, and then you can try delivering it to Agar.

But to answer the second part of your question, it's totally possible to continue the game without doing this quest, and you can always come back and try to do it later. MM1 doesn't really have a traditional quest line... there are certain things you must do to win the game, but in general it's very open and almost all quests are completely optional. Many can be repeated to get more experience, including this one. Doing this quest will eventually give you clues about how to finish the game, but you can finish without those clues if you figure it out yourself.

Still, it's best if you can get the quest to work. Hopefully giving the vellum scroll to your leader will work. Anyone else have any ideas?
Dropping it and redoing worked.

Perhaps I actually did complete it first time round and accidentally skipped the reward text.
mjhauber: Dropping it and redoing worked.

Perhaps I actually did complete it first time round and accidentally skipped the reward text.
Awesome, glad you got it to work. Speaking of the in-game text, though, did you know there is a fan-made patch to prevent it from going by too quickly? I found it helped a lot. You can grab it from this post, if you haven't already: