It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

The game had crashed a few times, mainly while training, so I tried to verify game, and now it won't launch. All I get is a white screen and something is loading, don't know what. The game that tries to launch I guess. Can't crtl-alt-del to taskbar and can't alt-f4 out. only log off. I tried to uninstall, keeping my saves, since I'm close to lvl 50. If anyone can help I'll be very grateful.
I should just have played my ancient physical copy, but the game was on christmas sales, and cost almost nothing, and when i saw it, i just had to play it at once :-)
Which game are you talking about? This forum is for the whole series.

It sounds like you might want to find and backup your savegames, then uninstall and reinstall the game.
Yes, i realizes too late that this is a forum for all the M&M games. The game is M&M 6.
There wasn't really anything major wrong with the game, but it crashed a few times during training, so I tried to verify game. After that, when i launch, I'm stuck in the launch. The moment before it says #DO and continues, there is a second or less where there is a gryish/white screen, and that is where I'm stuck.
I tried to totally uninstall the game with save games and all. Still the same . What really pyzzles me is, that I dug my old phisical copy of M&M out from mu cupboard, and i have played that on this rig, with no problems before, and it did the exact same thing.
I can alt-f4 out that white sreen I'm stuck at, and when I do, i can see a small square window, with some text, but it is gone so fast, that i can't get to read it, but i think it says something about 'can't access english language' I'm not sure, but something like that.
It doesn't seem like anyone else have had this problem, so mu hopes for help are not big. But not even being able to play my physical copy is a bummer. I've veryfied other games with no problem
Hmm, that's odd. The fact that your physical copy doesn't work either suggests that something on your system has changed which is preventing the game from working.

I'm afraid I won't be much help here. You might be able to try something drastic like a system restore to a point before you tried verifying the game (this assumes that the act of verifying it is what caused the problem), but that may be too inconvenient if you've been using your machine for other things too.

Anyone else have any idea what's going on here?

Since you mentioned the "can't access English language" message, I wonder: were you trying to play the game in a different language? Could that have something to do with it, like maybe verifying tried to switch it back to English and it got messed up?
Yes that is what I am thinking myself. I started the game again, right after veryfying, so I am sure it is the veryfying that somehow has caused the problem. I made an exception in my antivirus program for MM6 to be sure there hadn\t been added or changed a file AVG would dislike, but that did not help either.
Anyway, thanks for taking your time to answer, I will try to take contact to the GOG technical staff and see if they can come up with something
I have not tried to play the game in another language. Or actually, after writing my last post, I checked languages, and I had an option for German aswell, so I tried to set game to German language.It did not help either.
I am not sure it is what that message says. it is very small and only there for a fraction of a second. The only thing I am certain of, is that it says Error and something more
Yespa: Anyway, thanks for taking your time to answer, I will try to take contact to the GOG technical staff and see if they can come up with something
I totally forgot to suggest this. In my experience GOG support can take a few days to respond but they do respond and can be very helpful. Good luck!
GOG suggested that i installed the Greyface patch among other things. Since I had already tried the other things they suggested, I installed the patch, without much hope it would help. But it did! Game is launching again and I'm happy! Great service from GOG, thanks a lot to them and to you again for your time.