It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I just bought Messiah, installed it and the intro video played fine. Now I wanted to start the game, but just when the 3D mode starts and the first policeman is just standing, suddenly the screen starts flashing and the performance is dropping quiet heavily. I have to press "ESC" several times for the menu to show. Not any of the graphical options works.
My system:
Intel Core2Duo E8400
SB X-Fi Extreme Music
GTX260 Core 216
Windows 7 RC1
All drivers are actual, but I don't know how to fix the problem? Anyone out there who might know?
I'm seeing the same issues on Windows 7 RC1. I've tried the usual things (compatability mode etc) but to no avail so far.
I'm about to try the game on XP, but I wouldn't be surprised if the problems are 7/ vista specific.
Still no ideas?
mischa1981: Still no ideas?
same problem on 7 RTM, i'm looking for some tips
I'm using windows 7.
Open up the command line and go to the directory MessiahD3D.exe is located
Run the game with the -x flag
That is: C:\Program Files (x86)\\Messiah>MessiahD3D.exe -x
... and you'll see a dialog box with a choice of resolutions.
Then you'll see a screen like what's attached below.
Switch device to Direct 3D HAL not Direct 3D T&L HAL.
You should be OK to play the game. At least it works for me.
Beware that the Options screen might override the settings in the dialog.
untitled.gif (21 Kb)
Post edited December 27, 2009 by CoffeeJones
Hey great, it finally works fine on "7" :)
Thanks dude :)
How do you add the -x tag?
Metalgear132: How do you add the -x tag?
Do as he said, navigate there using the console and just launch the game with the -x parameter by typing - followed by an x.
Forgive me for updating an old thread, but I just purchased the game and thought this might also be helpful:

Rather than using command line, you can append the shortcut. For example, wherever your shortcut for the game resides (e.g., desktop, Start menu), right-click, select Properties, and paste the following in the Target field:

"C:\Program Files (x86)\\Messiah\MessiahD3D.exe" -x

I haven't really gotten into the game, yet. I'm just trying to get things to work. So far, fixing the shortcut and using the shortcut fix mentioned by CoffeeJones, et al, takes care of game issues, but yes, the movies are squeeshed.

Good luck!
Thanks alot! This helped me! Im on Win7 Pro 64-bit and this helped get rid of the graphical issues. Now I can even run it in glorious 1280 x 1024 res! ^^

I chose:

first box (Nvidia GTX 560ti) my gfx card (NOT primary accelerator!)
Direct3D HAL
1280 x 1024 resolution.

Yes the intro movie is a bit squeezed, a slight inconvience...but its a sacrifice Im willing to take, in order to get the game going :D

Thanks again!
Post edited September 19, 2011 by caffinemasta