It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So a couple of levels into the game I've encountered a bug that I'm assuming has to do with the game detects the player completing objectives.

The level I'm on is called "The Nebelwerfer Hunt" and at the VERY last part you are tasked with blowing up the Nebelwerfer artillery battery.

When I plant the explosives on the guns to blow them up, there is no timer and no explosion.

The thing that stood out to me was that the objective directions hadn't updated at all. It continued to read "Locate and destroy the Nebelwerfers. [4 remaining]" even after I have cleared the level of enemies and planted the explosives on every gun.

I checked youtube for some records and the guns are supposed to activate a timed explosion right after you rig them, so something was seriously up.

Google fu failed to return anything about a Nebelwerfer bug, so I turn to you all.
This question / problem has been solved by AdamRimage
Huh. Never had this bug.

My only suggestion is to reload an earlier save.
AdamR: Huh. Never had this bug.

My only suggestion is to reload an earlier save.
Yeah. I tried going back to the beginning of that particular part once and got the same result. I think I'll try a save before I was given the mission objective in question, and if that doesn't change anything I'll try the whole level again.

I've been playing on hard so I was putting off doing the level again from scratch >.>

Anyway I'll be sure to post what happens.
Yep! It was simple but it worked. I loaded just one checkpoint further back at the church part of the level, played through to the Nebelwerfer site and the explosives worked correctly this time. Thanks.