It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hey all, I need help with a certain problem here. I can't run Medal of Honor: Allied Assault without the opengl.dll fix (which runs fine) however the problem is, there is no fog in game, which in turn just looks nasty as you can see everything popping in. I have added screenshots as well.

I do have integrated graphics: Intel(R) HD Graphics 3000.

Is there anything I can do to sort this out?

Thanks.
Attachments:
Post edited February 10, 2016 by Shatteredspine6
I'm having the exact same problem. Ostensibly, there is a fix on Youtube: watch?v=sVlK2BCBQVM (GOG says I can't post links just yet, so plug that into the usual Youtube url).

However, I can't get it to work. Everything looks like it did before. Give it a shot if you want, and if it works for you then fill me in. It's extremely distracting, because enemies, tanks, and buildings will just pop into view yards away from you. If the fog and FOV works for anybody else, please post your config files, because I'm at my wit's end.
Could a savegame please be posted?

opengl.dll fix was mentioned, could this be the issue?

What does this fix do? Make it work on Intel graphics?

I have the original game, but also GOG version and old retro computers to test.
Yeah, it somehow makes it work on intel computers. How do you want me to post a save? Should I send the config files too?
I'm not sure. Maybe upload it to DropBox?

But does this only affect Intel cards, and works fine with ATI or Nvidia?

Because that's what I use.
No clue, I'm afraid. If it still works fine for you, then it's an Intel thing, and I'm SOL.
Here's the dropbox links. You have to add the www because GOG still isn't letting me post any links, I guess due to a spambot filter.

dropbox.com/s/y58x4og8fibcc2w/m3l1a0001.sav?dl=0
dropbox.com/s/tprcs9lc2z6v53s/m3l1a0001.ssv?dl=0
dropbox.com/s/hy270tzfo4groxb/m3l1a0001.tga?dl=0

These are the saves from the beginning of stage 3. Here is what it looks like to me: puu.sh/nFkWo/6a18d8e3c3.jpg

Everything, including the horizon, just pops into view. This is on the lowest resolution, after seeing if somehow that was the problem.

Here are the configuration files I am using:

dropbox.com/s/7moy6j88vfxrer7/newconfig.cfg.txt?dl=0
dropbox.com/s/idzjpkn3lvqky8q/unnamedsoldier.cfg?dl=0

NewConfig is the result of the video I posted earlier in this topic, from the Youtube video of the guy saying it restores the fog. I had no luck with that. It might be worthwhile if you compare it to the config files you have for the GOG version, or the original PC disc one if you have that too. I hope this helps, because having no fog is a little annoying.
avatar
Shatteredspine6: Hey all, I need help with a certain problem here. I can't run Medal of Honor: Allied Assault without the opengl.dll fix (which runs fine) however the problem is, there is no fog in game, which in turn just looks nasty as you can see everything popping in. I have added screenshots as well.

I do have integrated graphics: Intel(R) HD Graphics 3000.

Is there anything I can do to sort this out?

Thanks.
I know that I'm reviving an old topic, so I apologize, but I'm having the exact same no fog problem with the exact same video card (Intel HD 3000). Has anyone found a fix to this yet? I also have to use the opengl.dll fix in order to run the game and my PC is running Windows 8.0 (not 8.1) if that is at all relevant.