It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've dug up my old disc copy of MoHAA and it installed just fine but when I try to run the game I get the following pop up. I've tried running it in compatibility mode and I've tried putting disc 1 and disc 2 in my PC when I try to run the game... I can't stress enough that my PC had no issue recognising the discs during installation. Is there something I can do to fix this or should I just buy a new digital copy here? Either way I would appreciate some help
gamebug.png (167 Kb)
No posts in this topic were marked as the solution yet. If you can help, add your reply
The easiest thing would be to buy it here, sure. The thing is patched up to the newest version and works like a charm. The game is in the insomnia sale-cycle, I've bought it here myself as an owner of the original Warchest. Maybe you can catch it, it's a steal. The only other way would be to download a cracked exe or use miniimage. I'm not completely sure, but I think it shouldn't be illegal to do so if you own the game. But if you can catch the game here, I'd strongly advise to do so.

edit: some other thoughts:
Is your game patched to the latest version?
Do you use any virtual drives like Daemon Tools? I've heard that some of these can interfere with copy protections.
Did you try to set the game to different compatibility modes?
Did you start it as administrator?
Do you use your primary CD-rom-/DVD-rom-drive for the disc? Some copy protections only accept the d:/-drive.
Post edited March 05, 2015 by Wolfram_von_Thal