It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I bought Medal of honor Allied Assault from just 3 days ago. I have tried to install and launch the game several times. Installing is no issue, but whenever i launch the game i get the same error message over and over:

"Medal of Honor Allied Assault(tm) has stopped working: A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available".

I've tried to troubleshoot the game with different compatibility modes e.g. Windows XP (Service Pack 2), however I am continuously informed of the following error:

"Couldn't load default.cfg"

It is becoming increasingly frustrating, considering this is a purchased product.

I would deeply appreciate some further technical assistance.
I have not tested this personally but a recent Google search about this problem affecting many tells me it may work.

Please note, I didn't check the links here so you may need to Google some more to find a post with working links if these don't.

Sorry, that was ridiculously lazy. lol

I checked the links, both the DirectX 9.0c and openGL links work fine. Try this and let us know how you make out. I have a feeling this will fix it.

By the way, from what I've been reading it is probably unable to load that config file because the graphics system is failing to initialize. I've seen screenshots with this error in the console showing the graphics system failing to load which points to problems with the DirectX version install as well as OpenGL on a newer system.

This is what makes me hopeful the above mentioned fix will work.

I hope it does for you. Please let us know.
Post edited April 22, 2015 by dirtyharry50