It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hey,

I just purchased MoO 2 and I noticed that the performance isn't all too good. After about 3 or 4 minutes the music starts to stutter. The game in general feels very sluggish and unresponsive. I used to play it under Win98/XP just fine. I would assume that the Dosbox configuration is not optimized? I tried all graphics modes, some are better than others, but the game still isn't as smooth as I like it to be. I searched for a tutorial/faq, but couldn't find anything. Any tipps on how to optimize the performance of this badboy?
You might try adjusting the frameskip. Ctrl+F7 and Ctrl+F8 decrease and increase this setting respectively while the game is running in DOSBox. You can use Alt+Enter to toggle between full screen and a window. In windowed mode, the title bar will have the current frameskip value. If it feels a bit better with a higher value, your machine may be having trouble keeping up running the game within DOSBox.
It was at 0 and increasing it made it feel even more sluggish. I am running on a Core 2 Duo@2.2GHZ, 3GB-Ram, Nvidia 8600 GT M, windows 7 ultimate 32 bit
Dosbox isn't the most efficient app. My quad-core Phenom @3.4Ghz was supposedly lagging Grand Prix 2.
Odd while it is true that DosBox is inefficient (it is emulating the DOS environment to be fair), those specs should be good enough to run MoO2 with no problems. Since increasing/decreasing CPU cycles didn't work, maybe try this?

http://www.gog.com/en/forum/master_of_orion/game_switches

I'm not sure it will help, but maybe ...
avatar
Benthetraveler: Hey,

I just purchased MoO 2 and I noticed that the performance isn't all too good. After about 3 or 4 minutes the music starts to stutter. The game in general feels very sluggish and unresponsive. I used to play it under Win98/XP just fine. I would assume that the Dosbox configuration is not optimized? I tried all graphics modes, some are better than others, but the game still isn't as smooth as I like it to be. I searched for a tutorial/faq, but couldn't find anything. Any tipps on how to optimize the performance of this badboy?
I've a similar problem. Could you please check if it gets better in windowed mode?
I always try to tinker the setup.ini in the gamefolder. Usually the frameskip and Cycles fixes those problems.

Sorry, I cannot give you much more help.