}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I have been playing MoO2 on windows 10 without dosbox as in the windows version of the game and it works practically flawlessly, though i needed a mouse fix for it, the mouse pointer kept freezing and disappearing ingame.

I don't even need compatibility settings, it worked fine, though i would make sure to have dplay.dll in the game directory.

I haven't tried multiplayer, but its a turn-based game, MP in those type of games is stupid, but thats just my opinion.
avatar
Perscienter: I've adjusted the blocksize and prebuffer settings, but I can't sort out the sound stuttering issues under Windows XP, which seem to be rampant.

I've also tried different graphic modes. It runs perfectly, except that a diplomat screen, battle screen or another switch of the screen will sooner or later trigger the stuttering.

Did someone fix this successfully?
I found a solution here, hidden in one innocuous little line:

"I had some problems with the audio skipping, which I resolved by opening DIG.INI and manually changing the IRQ to 5."

On inspection of the DOSbox sound config and the game sound config file (DIG.INI), it turns out DOSbox is set to use IRQ 5 while DIG.INI is set to IRQ 7. I changed the setting in DIG.INI to match DOSbox, but it would probably work either way. That was the last of my sound issues.
avatar
Perscienter: I've adjusted the blocksize and prebuffer settings, but I can't sort out the sound stuttering issues under Windows XP, which seem to be rampant.

I've also tried different graphic modes. It runs perfectly, except that a diplomat screen, battle screen or another switch of the screen will sooner or later trigger the stuttering.

Did someone fix this successfully?
avatar
Lobosolitario: I found a solution here, hidden in one innocuous little line:

"I had some problems with the audio skipping, which I resolved by opening DIG.INI and manually changing the IRQ to 5."

On inspection of the DOSbox sound config and the game sound config file (DIG.INI), it turns out DOSbox is set to use IRQ 5 while DIG.INI is set to IRQ 7. I changed the setting in DIG.INI to match DOSbox, but it would probably work either way. That was the last of my sound issues.
Wow! Thanks! For a very long time there have been problems with the sound settings GOG setup for MoO2. Now we need a tiny update to the installer too for new players.
avatar
philtrev: Game runs with original Dosbox setting but my mouse stutters like crazy. Upping the sensitivity just exaggerates the stuttering. If I try moving the mouse slowly it sometimes won't even move. What else can I do to fix this?
This is caused by running it fullscreen. Mouse acceleration works differently in Win7+ and Moo2 doesn't know the difference, it's using the old algorithm when full screen and that causes dead zones (not moving at all when barely moved) and crazy zipping acceleration. To fix this you HAVE to play it windowed. There's no way around it naturally, you can try lowering the sensitivity in the dosbox conf file (it's at the top). But that will not stop the dead zones in fullscreen.

What I do is lower my desktop resolution to something that's a divisor of 640x480 (I use 1280x960 with a 2x scaler in dosbox for pixel perfect 1:1 ratio) then play in a window, and use helper apps to strip the border off the window and center it on the screen. Basically it's pseudo-fullscreen, but it's using your native mouse settings without any in-game wonky acceleration. Your movement feels exactly as it does on your desktop. And you can alt-tab at will, doesn't freeze the game, etc. For long auto-combats I just switch to chrome and check reddit :P

[code]
fullscreen=false
windowresolution=1280x960

scaler=normal2x
[/code]
avatar
Kornstalx: ... For long auto-combats I just switch to chrome and check reddit :P...
Try pressing the z key for fast auto combat.